Image not booting

I have a new Rock64 RK3328 Board and i want use the DietPi OS.

I downloaded the latest image from here. But it´s not booting.

Any idees?

How did you burn the image to the SD card?

You are not along. My board does not boot neither!

Updates: I found the problem. The USB cable I used to power Rock64 has thin Power/Ground cable that is not able to deliver enough power to Rock64. After changing the cable, not it boots perfectly.

I tried Win32DiscImager, Pine64 Installer and Etcher to burn the image

For energy i tried 3 different adapter with different cables.

The image from

https://libre.computer/products/boards/roc-rk3328-cc/#tabs_desc_692_4

is booting.

Is it possible that one image need more energy than another?

According to my USB voltage meter, it only requires 5V maximum 0.6A power → 3Watt will be enough to drive Rock64. The first wire I used to power Rock64 has thin wires, it cannot power Rock64 with both Dietpi and Stretch Mate. I don’t think image is the key. Your board maybe fried or your SD card does not work properly.

I am having a similar issue with Pine64. Other images are working with both 512 and 1G versions but I can’t get the 6.1 to boot on either. I’ve tested with multiple power sources / quality cables / SD cards. Any update from you guys?

I don’t remember Rock64 has 512MB board? I have 4 Rock64, they all boot fine with proper power adapter.

i have tested a few images but no one will boot. I have a new power sources, tried other sd cards

i have the 4gb board

It would be very nice if someone could give me an advice for a functioning image

I also cannot get it to boot for the rock64 1gb, 16gb sd card with good power adapter. Other images boot.