I'm having trouble seeing a mounted USB drive

That is to say that after I mount the drive in the Drive_manager, I can’t see it from my windows 10 laptops.

I can see the Pi and, after some trouble, can open it as part of the network, but the directories I see appear to be on the Pi’s SD card, as they are all empty.

The drive is powered by the Pi 3B’s USB port, not an external hub (And has no way for external power), but it has worked with DietPi in the past as well as a Raspbian server, and I’m not getting any lightning bolt indicators while running the Pi.

The drive is an NTFS formated WD EasyStore 2T unit, and I don’t think it’s having any problems as it’s read fine if I plug it directly into one of my Windows computers.

So, what’s the next step it troubleshooting to get this USB drive visible so I can continue backups and what not?

Try installing autofs and ntfs-3g

# apt-get install autofs ntfs-3g

ntfs-3g is an NTFS driver, which can create, remove, rename, move files, directories, hard links, and streams; it can read and write files, including streams, sparse files and transparently compressed files; it can handle special files like symbolic links, devices, and FIFOs; moreover it provides standard management of file ownership and permissions, including POSIX ACLs.


Mount /dev/sda1 to /mnt/windows:

    ntfs-3g /dev/sda1 /mnt/windows 
    mount -t ntfs-3g /dev/sda1 /mnt/windows 
Mount the ntfs data partition /dev/sda3 to /mnt/data with standard Linux permissions applied :
    ntfs-3g -o permissions /dev/sda3 /mnt/data 
    mount -t ntfs-3g -o permissions /dev/sda3 /mnt/data 
Read-only mount /dev/sda5 to /home/user/mnt and make user with uid 1000 to be the owner of all files:
    ntfs-3g /dev/sda5 /home/user/mnt -o ro,uid=1000 
/etc/fstab entry for the above:
    /dev/sda5 /home/user/mnt ntfs-3g ro,uid=1000 0 0 
Unmount /mnt/windows:
    umount /mnt/windows

That might help your system identify, and mount ntfs formatted partitions

Thanks for your reply!

I already had NTFS-3G on board; I think it may have been there from the fresh installs. When I try to manually mount, like you suggested, I get “Mount is denied because the NTFS volume is already exclusively opened.”

That part jives with me trying to mount it via the drive_manager, and viewed through there, it has an “Mnt,” prefix way off to the left. Unmounting it fails because the user data is on this drive, but I could easily move it elsewhere if I need to.

I moved the user data to this external, thinking it may help focus on that drive with no results. Would moving the swap file there do anything? I don’t think so, but I’m grasping at straws here.

I thought I’d update this. The drive is now being seen by Windows. That coincided with the Pi no longer showing up in “Network,” and instead showing up in “Network Locations,” under This PC.

I can even see that it lists 1.63Tb free of 1.81!

It seems like I should be home free, but the only thing I can see are empty directories: downloads, Music, Pictures and Video.

It seems like a step in the right direction. I’m going to swap from Samba to ProFTP and see what, if any difference that makes while I wait for some more help from there.

Did you solve this. I cant find it from my lap :cry:

No, I haven’t yet.

I decided to see if a new, fresh format on the HDD would help and the situation regressed to no longer being able to see the drive capacity. I tried to copy a few hundred gigs of stuff I want to back up and got an error about not having enough space, so the directories I’m seeing in Windows are no longer on that drive, but on the SD card.