I`m having trouble pointing my domain to my server

###trouble pointing my domain to my server

  • DietPi version | Armbian 23.8.3 bookworm aarch64
  • Distro version | bookworm
  • Kernel version | 5.10.160-legacy-rk35xx
  • Architecture | arm64
  • SBC model | Orange Pi 5 (aarch64)
  • Power supply used | (EG: 5V 1A RAVpower)
  • SD card used | (nvme corsair mp600)

Additional Information (if applicable)

  • Software title |Wordpress,OpenSSH,Fail2Ban,Apache,MariaDB,PHP,Certbot

First of all i am an absolute beginner. So excuse my lack of knowledge for this issue. I managed to create an homepage on my orangepi5 with the help of wordpress and a subdomain at dnshome.de.
Now i got me my own domain http://www.svenkriegelfotografie.de/
but it `s saying Server not found.
if i use the dnshome trail, everything works fine
Sven Kriegel Fotografie
i changed the nameserver to my ip -no result
are the any settings i need to adjust at the orangepi setup?
Thank you in advance

did you forward ports on your router correctly to DietPi system? At least port 80/443?

yes i did

did you tried to use your external IP address to exclude DDNS?
Best is to try from mobile phone connected to mobile network (not wifi)

your dns points to internal ip

Pinging svenkriegelfotografie.de [192.168.178.11] with 32 bytes of data:

2 Likes

indeed. Looks like it’s the FritzBox router

root@DietPiProd:~# dig svenkriegelfotografie.de

; <<>> DiG 9.16.42-Debian <<>> svenkriegelfotografie.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19762
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;svenkriegelfotografie.de.      IN      A

;; ANSWER SECTION:
svenkriegelfotografie.de. 3600  IN      A       192.168.178.1

;; Query time: 110 msec
;; SERVER: 9.9.9.9#53(9.9.9.9)
;; WHEN: Thu Oct 12 12:35:21 CEST 2023
;; MSG SIZE  rcvd: 69

root@DietPiProd:~#

How do you update your DDNS?

https://www.dnshome.de/dyndns.php?ip=

it`s that what you are talking about?

quest is how you update your external DDNS IP? is your FritzBox doing it? Did you do this manually? How?

2 options. Either your registar has some dynamic dns option which you can use to update your IP.
Or you point this domain towards the dnshome and let that reforward you to the actual IP.

This is the best hint so far. I managed to get to the apache default site. thanks alot!

1 Like

Just to let you know : I had to add a CNAME entry of the dyndnshome.de subdomain to my domain hoster. Now i just have to figure out how to change the apache2 default to my wordpress