I can't unmount an external USB HDD

Hi there!

I was using an old 320GB 3.5HDD on my Raspi B+ with an external case. I moved to the disk the swap file and the dietpi user data and worked OK the last year. I bought a new external 4TB HDD and put it on the Raspi, so I returned the swap and dietpi user data to my sd (64GB) to disconnect the old disk. Everything went ok until i tried to unmount the old disk:

On dietpi-drive_manager I try to unmount the old drive and always fail. I tried to change the fstaab erasing this disk information and did not work. I have rebooted a lot of times an nothing seems to work. I did not unplugged the disk until i can unmount it because I am afraid my system gets frozen.

Can anyone tell me how to force unmount the drive? The order unmount does not exist in the system and when I try:

dietpi-drive_manager umount [/dev/sdb1|/mnt/Datos]

this is what i got:

-bash: /mnt/Datos]: No existe el fichero o el directorio

Any ideas?

Hi again!

I tried to check and repair the drive and system could not unmount it. This is the message I received:

Thanks for the help!

pls can you post following

df -h
cat /etc/fstab

Thanks a lot! I found my mistake: I have my user home folder on that disk and (now sounds obvious) that were the reason I could not unmount the disk.

Finally, I copied the entire content from my old disk to the new one, changed my home directory to the new disk, and after a reboot i could unmount and disconnect (forever I hope) the old noisy disk.

Thanks for your help!

yeah that’s a good reason for blocking the unmount :slight_smile:

good that you found it