I can't get Dietpi to run on a Rock pi 4C_plus. Is the problem known or am I just too stupid?

I can’t get Dietpi to run on a Rock pi 4C_plus. I get to for the login after the installation and that’s it. The RockPI is frozen.
I’ve already tried a few things. Image written directly to emmc and worked without emmc. The result is always the same. Is the problem known or am I just too stupid? :slight_smile:

32GB eMMC / 256GB SD_Card / Rock_pi_4C_plus

Welcome to our community. Until now, we are not aware on such issues and you are the only one reporting it at the moment.

Can you share some more information. Are you going to login via SSH or some local console? Can you share a picture of what you are seeing on screen? Once the system is frozen, are you able to login via another SSH session?

You are right, my post was a bit confused :slight_smile:
ok in order.
The hardware is a brand new ROCK PI 4C_PLUS including 256GB M2-SSD and 32GB eMMC.
With no LAN available, I only have WIFI.

I copied the DIETPI-OS to an SD card with Etcher.
Since the RockPI does not boot with an inserted M2 SSD, I removed it.
Dietpi-os boots with LAN error (totally ok) and then hangs at login. No keyboard is accepted, I cannot press RETURN as requested to go to login.

Then I went a different way. I installed Debian because that works. Activate the WIFI in the Debian os and copy the Dietpi-os to the eMMC according to these instructions from step 3.
(Rockpi4/install/eMMC - Radxa Wiki)
Then remove the SD card and restart. The result is the same.
Since I don’t have a LAN, I can’t test whether ssh works.
As a last attempt, I copied the dietpi-os to an SD card with etcher and booted my pc with ubuntu, then mounted the SD card and adapted the config files to my network.

So LAN switched off and WIFI switched on and entered the SSID and the PASSWORD. I have tried the settings to get directly to the desktop with autologin but that has all been unsuccessful. It always ends with the login window.
The AP is also not connected. So no SSH either.

After about 30 attempts I’m at a loss. Any ideas?

could you perform a new flash of the image to SD card and adjust following values on the dietpi.txt file


As well add your WiFi details into dietpi-wifi.txt

# Entry 0
# - WiFi SSID: required, case sensitive
# - WiFi key: If no key/open, leave this blank

This should start an automatic installation without user input. However, if WiFi is failing, installation will stop at the beginning on some error screen.

That’s correct. There is no desktop installed at the beginning. You would need to pass first installation steps to be able to install software.

Genau das hatte ich schon mehrfach gemacht.
Mit einem Raspberry 4 funktioniert das auch genau so.

The issue has been settled for now. The ROCK PI 4C_plus died an hour ago. LEDs off and the fan twitches from time to time.
The PI was probably a Monday device from the first series. And I almost think the device was a bad buy. I only bought it because there is no Raspberry 4B 8GB available for a fair price.

Now I’m curious what the warranty looks like.

bad to hear that the device has been died. I hope you are able to get your money back.

which image DietPi should i use for rock pi 4c+?

Did you try our image for the Rock Pi 4?
I can imagine itwill not work, on official radxa site they have 3 different images for the rock pi 4 family. One for thee 4 C, one for the 4 C plus and one for the rest. But you can try.

You could also try install the official radxa image (debian buster with XFCE) and run the dietpi install script afterwards.