I can no longer access Aria2 WebUI since I've set up my Nginx Reverse Proxy


I have recently set up a Reverse Proxy with Nginx for all my services.
I’ve succeeded to put behind it most of them.

But I’ve got an issue with Aria2. It is reachable using a remote app for Aria2, using the domain and the port 6800. But it is no longer reachable from the WebUI. I was previously accessing it on local network with [localip]/aria2/docs. But now I can no longer access it even on local network. I think the issue is a conflict between Aria2’s SSL mode and my Nginx.

Here is my aria2.conf : https://pastebin.com/E6JKUsts

What settings should I check to fix this ? Maybe disable SSL mode ?
The final objective would be to set it behind my reverse proxy too with a subpath [domain]/aria2. But I didn’t find any nginx configuration example in the official docs.

Thanks in advance for your help,
Have a great day

I succeeded to fix it myself !

The solution was to move the folder from /var/www/aria2
(this folder in fact contains only aria2-webui and not aria2)

to /var/www/[mysite]

And now I can access it by going to [mysite]/aria2/docs

And it works and it’s SSL secured !


yes Aria2 Gui is a normal web site that is accessed via normal web server. I guess you setup the revers proxy in a way expecting a web site located in a specific document root. On default, DietPi is using /var/www/. Something you need to keep in mind if you install other web server applications. They could suffer from the same behaviour of your revers proxy :wink: