how to update dietpi nodered?

Hello, I do have two rpis running same dietpi releases 6.28
both of them have installed nodered via dietpi-software.

Strangely one of them has got version 1.0.3 but other one has got 0.20.7

How that’s even possible and how I can keep both versions same?

(yes I indeed did all updates/apt update/upgrade and everything…)


seems like issue with an front-end?

cos packages seems like same:

dietpi@pidns:~$ apt list nodered
Listing... Done
nodered/testing 1.0.6-1 armhf


dietpi@garden:~$ apt list nodered
Listing... Done
nodered/testing 1.0.6-1 armhf

but fe looks like this:


many thanks for your report. Best to my knowledge, Node-Red is not installed via apt package. It should be installed via Node-Red install script. Therefore executing apt will not update your Node-Red installation.

We provide a script to install Node.js, npm and Node-RED onto a Raspberry Pi. The script can also be used to upgrade an existing install when a new release is available.

This script will work on any Debian-based operating system, including Ubuntu and > Diet-Pi> .

therefore pls run re-installation of Node-Red as follow

dietpi-software reinstall 122

btw latest release is node-red@1.0.6

Thank you very much for your helpful comment.
It worked and both versions are now same.

This got me wondering tho … is nodered only one specific or I need to besides apt update & upgrade run dietpi-software reinstall xxx on regular basis?

can’t this be somehow automated?
as it is not clear from dietpi-software menu that this needs to be reinstalled in order to get update



this depends on the software titel itself and the way how it is provided by the vendor. Some title’s are managed via apt, some internal software update function and some via simple re-installation. There is no black and white answer unfortunately. But this should be same as on all other Debian based OS, as the way how to update is something defined by the software provider/developer.

trying to see if its possible to upgrade node-red to the latest 1.1.0 release.

From the node-red workspace it says i have 1.0.6 installed.

the NR website say run

bash <(curl -sL

but this script detects this was a DIETPI install so does not run and suggests uninstalling and the install Node-Red.

i’d like to know if doing the above i would presume it will loose all the Pallets installed and all the work flows and other settings?

I figured i’d try it out on the VirtualBox Buster VM image you can download however even from a fresh brand new install
from this VM, Node-Red fails to install at all says there some issue with node-red Service file.

I tried this a couple of times and no joy.

So i dont really want to attempt this on my working 1.0.6, if the Dietpi-Software isn’t ready yet to push/upgrade to latest Node-red

Can I get some clarity if it’s possible without having to start all over?


if you are not sure on the upgrade, just run dietpi-backup before. It should safe your data and you could run a restore if needed. As well you could clone your SD card to get an exact backup/copy created. It’s always recommended to perform a backup before upgrading some software.

npm up -g --unsafe-perm node-red

The installer script is for official fresh Raspbian only. It expects the “pi” user to be actively used etc. As genetic install method npm is used (which basically does the installer as well, besides some pi/Raspbian only config steps).

Thanks Mich… that worked perfect and painless… updated completed in seconds and can confirm it now version 1.1.0.

Had to just to a stop/restart of the service for it to pick up the new version.

thanks again.

I added it to our docs:

I have been throught this process and cannot get the node-red on my rpi Zero above ver 0.20. Dietpi is at 6.34.2 . Are there restrictions on the board type for node-red?


can you share output of following

npm install -g --unsafe-perm node-red