How to make DietPi max at nothing greater than 1080

I am looking for a way to add code to config.txt or dietpi.txt to be able to keep the boot of DietPi at a 1080p resolution for the HDMI port.
When I hook my Pi400 up to my 4k TV, it kicks over to a high resolution and runs very very slow.
When I hook the DietPi install to a computer monitor (or other TV) that maxes at 1080p, it runs perfectly fine.
A little new to the operating system and it’s workings - but I have figured out enough to be able to edit config files.
Probably simple, but looking for help on what code to add to what file.
And I haven’t been able to find my answer yet.

Creating a bug report/issue

I have searched the existing open and closed issues

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
    bullseye 0
  • Kernel version | uname -a
    Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 BST 2023 aarch64 GNU/Linux
  • Architecture | dpkg --print-architecture
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
  • Power supply used | (EG: 5V 1A RAVpower)
    5V 1A
  • SD card used | (EG: SanDisk ultra)
    SanDisk Ultra 64GB

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. Boot DietPi on PC monitor that maxes at 1080, everything runs fine.
  2. Move device to HDMI/TV that can do 4k - and boot process takes 5min and system chugs afterwards

Expected behaviour

  • What I am experiencing probably SHOULD be happening, without additional code changes.

Actual behaviour

  • What SHOULD be happening.

Extra details

Did you tried changing resolution using dietpi-config?

Have not. Let me use dietpi-config and see what I can find. Like I said… pretty new to this. I’ll report back soon.

So after changing the resolution and saving in dietpi-config, it seems to break the autolaunch of the software that was in the image on my sd card. (Amiga Game Selector 2.5) normally after the OS boot, amibery launches. But not sure how to get amiberry to launch in this case now. Tried messing with the dietpi’s autolaunch settings in dietpi-config, but no dice.
Not sure why the resolution change would mess with the application boot but it happens. Reimaging my SD card now as I can’t figure out how to get the amiberry setup to launch after the login. Back to step 1.

Um… forget it.
I used some old information I had on an old build.

(Putting this code in the config.txt)

And it didnt work the first time… BUT

What I found after a very stupid moment is that I had my HDMI cable plugged into the wrong port on the Pi400.
Once I moved my cable to the proper port and booted, I was instantly brought in - in 1080 mode.

I feel so stupid. lol.
Oh well. Hopefully this helps someone else out there.

1 Like

at least you found it :smiley:
thx for sharing.

Anyone care to elaborate on the difference between the two ports? I couldn’t dig anything up in my short search other than there being a rumor that “won’t die” over which port you must use. I’m not sure why this would matter.

That’s a RaspberryPi Engineer that squashes that rumor btw.