How to force Pi to use Nord Meshnet?

I have Nord, and I want to use their Meshnet to connect my devices (right now it’s just my phone) through my Pi-hole then VPN. NordVPN is not an option for “dietpi-software”, so I have no idea how to download and install it.

My goal here is just to get the Pi to register on Meshnet. I thought TailScale would do something similar so I tried that first, but apparently not. Also how do I delete TailScale since it doesn’t do anything for me? I appreciate any help, thanks!

Did you configured TailScale to connect to your account? Anyway, you can remove it using dietpi-software > Uninstall.

Is is not a software option, but VPN options are available via dietpi-vpn. But not sure if this is working for Meshnet. Something you need to try yourself.

In regards to TailScale, I could connect my devices together, but devices (especially my phone when remote) weren’t being forced through the Pi-hole (which was why I installed it to begin with). I uninstalled it after setting my Pi as the exit node because my computer wasn’t getting an internet connection at all.

I’m willing to reinstall it and set it up again if it will get me to my end goal! I guess a better question would be: what is the best software to get to my remote devices to connect to my Pi and route traffic through it? Be it TailScale, VPN options on dietpi-software, or otherwise. Preferably, I’d like a very beginner-friendly solution that is hard to break because I’m not smart enough for most of this.

You need to login to Tailscale web page and activate MagicDNS if I’m not mistaken.

Personal I’m using native Wireguard server installed on my Pi. This way all my mobile phones are able to connect back home to use Pihole while out. It might not that easy to configure but there is a software option PiVPN, offering a command line interface to manage clients.

I apologize for the delay, I was having Tailscale difficulties and could not access my dashboard. My MagicDNS was enabled by default, but it doesn’t seem to be configurable or give an option for routing.

did you already checked following Tailscale KB DNS in Tailscale · Tailscale

Apologies again for the late response, but I figured it out. For anyone who stumbles upon this thread, here’s how a novice like myself solved my problem. I gave up on Nord’s Meshnet, but this was a simple fix and turned out better than I hoped: use the Pi-hole as a Tailscale exit node. Now my devices work better than ever, I get ad/tracker blocking 24/7, and I can use services remotely from my home network.

The official guide was very helpful, thank you for your patience.