how to fix a readonly rootfs partition?

Hi Everyone,

I recently updated Dietpi on my Raspberry Pi Zero W to 6.28 and after 1-2 days it crashed. :cry: I had also updated other things, notably I added python 3.5-dev because my installation of Domtoticz needed it to run plugins. I am not sure if the updates had anything to do with all this or whether it is simply a problem of my cheap microSD (32 GB) from AliExpress. My Raspberry Pi Zero runs 24/7 and has done so for the past couple of months without a problem; there has not been an unexpected shutdown or power outage.

Anyway, I have been unable to fix this problem because the rootfs partition is read only. I am able to mount the boot partition with no problem and fully access it, but unable to mount rootfs. I checked the card with Gparted and other utilities and everything looks to be there, but I couldn’t make any changes whatsoever. I was able to make a backup with ddrescue and everything completed flawlessly and the size of the image file looks to be correct. I ran different utilities such as fsck, fdisk, testdisk, etc. but no luck. They were able to find problems but were unable to make any changes because rootfs is read only. Apparently the superblock may be corrupted. Looking at the console log when booting the microSD on the Raspberry Pi Zero, the boot hangs when trying to access the filesystem partition with an I/O error.

I make regular backups of the entire card but couldn’t simply replace everything since I was unable to format the card because it was read only. So it appears I may need a new card (easy solution), however I wouldn’t mind trying to still fix this (hard solution) since I would need to replace some of the data and settings lost which in itself is extra time and work. So my question is this: since the boot partition is still accessible and works, is there a utility or setting within this partition which can be used to fix the read only rootfs partition? If not, is there a way that GRUB or some such utility can be added to run in the boot partition when the system starts so that rootfs may be fixed?

I generated a lot of logs and other info which would too much to include here, but they can be accessed at the following link:

The files are as follows:

boot.txt: console log of the Raspberry Pi Zero W when booting
ddrescue.txt: screenshot of the completed image backup using ddrescue
rescue.log: log file generated by ddrescue
rpi0.txt: console results when using fdisk and fsck
testdisk.log: log file generated by testdisk

Thanks in advance for any help.

I am having the same issue. I have tried setting up from scratch and end up with the same failure. Dietpi is now completely unstable on a Raspberry Pi from what I can see.

I have tried 3 separate Raspberry Pi’s (3Bs) that I have laying around with 4 separate SD cards of different manufacturers and sizes (8gb/16gb/32, ScanDisk Ultra/Toshiba Exceria/Toshiba). Some last less than an hour before they get this fault, longest lasted less than 24hours.

I’m not installing anything crazy. Strickly using the dietpi-launcher to install Sonarr/Radarr/NZBGet and mounting a drive from another SBC that is running dietpi (luckily an ASUS TBS). Thats all.

It continually locks down with “rootFS is currently Read Only (R/O)”

Can’t access dietpi-config or anything. Tries 7 times not.

Have you had any luck?


this is a know issue if you updated to DietPi v6.29.2
pls follow this GitHub post for further information and a possible workaround.