How do I toggle "USB boot support" to OFF?

Trying to set up an rpi3 with DietPi_RPi-ARMv6-Bullseye. Flashes to micro SD card and boots. When I get to dietpi-config > Advanced Options, the USB boot support is [On]. How do I change it to [Off]?

I am running as root, so no priv issues.

Everything else on that menu page toggles with the space bar. Pressing the space bar when USB boot support is highlighed just refreshes that page without updating anything.

I assume I may have caused this problem by trying to turn on USB boot support by adding “program_usb_boot_mode=1” to the end of the /boot/config.txt file yesterday when I was trying to get USB boot working. I ran into problems. I have reflashed the micro SD card and I want to go back to micro SD card boot all the time, even when I connect an external USB HD to hold my media files.

Any suggestions how to toggle that setting in DietPi-Config > Advanced Settings?

tia

I guess there is no reason to turn off that setting. Boot will look to the SD card first. If that fails the setting is checked to determine whether to try booting from the USB devices. So as long as I keep my SD card in, and working, I don’t need to worry about this setting.

If that is not right, please jump in.

We should add an informational prompt when it’s on already:

This option does not set the boot order but only enables USB boot support (as fallback if no bootable SD card is attached) on RPi 3 permanently by programming the respective ROM. If that has been done already, it cannot be reverted. On RPi 3+ and 4 this is enabled by default. Only on RPi 4 where the bootloader is stored on an EEPROM, the boot order can be changed as well.

just as reference the official RPi documentation Raspberry Pi Documentation - Raspberry Pi Hardware