How do I setup with WiFi on NanoPi Neo Air?

I’m looking for instructions on how to get WiFi configuration loaded onto my NanoPi Neo Air during setup. Ideally I’d be able to place a file on the SD card, however the NanoPi NEO Air uses eMMC so rather than having the fat based boot partition that I could write a network config file onto, the entire SD card is imaged with what I think is a flasher utility that loads the eMMC. I’m used to working with SBCs that run off the SD card, the eMMC is just throwing me for a loop on this one.

Can anyone clear up how I can get WiFi configured on the NanoPi Neo Air as part of a headless setup?

Welcome to our community.

I guess you are flashing an *.img file to eMMC? If yes, you could open the image with a program like 7zip and update configuration files inside the image.

Anyway, the Neo Air should have a SD Card slot as well. Theoretically you could try to finish setup on the SD card an copy the data to eMMC later on.

I tried modifying the image, unfortunately it did not work and I have no clue why at this point since I have no ability to connect since it isn’t loading. I guess I will have to wait for a serial adapter to come so I can log in via a serial terminal and try to figure out how to do it, but this whole process is beyond what I could ask a user to do, editing wpa_supplicant.conf for RPiOS on a fat partition they could see was pushing it for most of them as it was.

The fat partition is specific for RPi OS. Other images like Armbian don’t have such.

What files you tried to modify?

I modified /boot/dietpi.txt and /boot/dietpi-wifi.txt, then repacked it into an image file.

ok we would need to wait on the console access, otherwise it’s hard to determine what the issue might be.

And without it working I don’t have access to the console. The fat partition that Raspberry Pi OS uses makes it quite easy to get a headless setup going, I never really realized just how much easier that fat partition makes things.

Basically, this is nothing we are influencing as this is the layout of the used Armbian image.

Thanks for letting me know, I think I’ll have to figure out a hotspot style configuration solution.

I never got it working with an altered image nor did I ever get the serial connection to work. I did burn the image, then before putting it into the NanoPi I used a Raspberry Pi to mount and edit the 2 dietpi files, then put it into the NanoPi and it worked.