How do I create folders on external Hard Drives?

so this is I guess a very dum question but I can’t get to create folders on external hard drives (for sabnzbd and respective my media library)

I mounted and formatted both hard drives via the diet-drive manager

then I tried to “cd” into the hard drives (e.g. /dev/sdb1/ ) in the terminal as “root”. and after the mkdir a folder. but already for “cd” here it says:

-bash: cd: /dev/sdb1/: Not a directory

so cannot even get to the hard disc to create a folder.

when going in the sabnzbd settings to the hard drive it says I have no access to the drive (I assume sabnzbd doesn’t run as root user)

sorry im a total noob and in the beginning of learning

First, drive need to be mounted. For this, select the drive inside drive manager and specify the mount point. Once done, you can navigate to the drive

cd /mnt/<your-name>

thanks for getting so fast back. as I understood both drives are mounted:

under mount control I can just unmount it?

under mount control I can just unmount it?

Same goes for the second SSD

once mounted, leave drive manager and use cd command to move into the drive

that’s the directory on your dive

This is how you named it while mounting

ahhh damn. thanks. im going to try it.

creating the folders worked now!

But when trying in sabnzbd settings to change the folders to the new ones on the external I get following message

I created all folders with root

you need to change owner to sabnzbd user. Or even better to dietpi groupe to be able to exchange with other apps

chown dietpi:dietpi /mnt/<your-path-to-folder>

do I need to do that for each folder? or is the mount drive enough and it parents its down to the subfolders?

just for the folder you like to access by sabnzbd. If there are other subfolder, you could use -r option on cd command

mhhh somehow I can’t get it to work.

i have created a incomplete, complete, watched, scripts folder

then given
chown dietpi:dietpi /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd/incomplete

but I still can’t save and getting error access in sabnzbd


chown -r dietpi:dietpi /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd

can you share following afterwards

ls -la /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd



ah sorry it’s uppercase -R :smiley:

chown -R dietpi:dietpi /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd
chmod -R 775 /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd
ls -la /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd

BTW: there is no need to do screen prints. You should be able to copy everything from SSH terminal directly.

root@DietPi:~# chown -R dietpi:dietpi /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd
chmod -R 775 /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd
ls -la /mnt/c5ef1ad4-f767-41c0-b301-5885583d5b25/sabnzbd
total 24
drwxrwxr-x 6 dietpi dietpi 4096 Dec 17 19:58 .
drwxr-xr-x 4 root   root   4096 Dec 17 19:56 ..
drwxrwxr-x 2 dietpi dietpi 4096 Dec 17 19:58 complete
drwxrwxr-x 2 dietpi dietpi 4096 Dec 17 19:58 incomplete
drwxrwxr-x 2 dietpi dietpi 4096 Dec 17 19:58 scripts
drwxrwxr-x 2 dietpi dietpi 4096 Dec 17 19:58 watched

fucking legend you are. it worked.

will I get into similar issues when configuring sonarr/radarr/prowlarr? do you have any clue (if not I will probably come back to you :smiley: )

depends, if you will use different folder :wink:

Basically, solution will be same. Change user and group to dietpi + adjust folder permission to 775

Roger that captain. will give my best