Home Assistant issues after latest upate

Hi,

I am running Dietpi 8.10 on RPi 4 Model B.
Since the last update I have issues with Home Assistant.

The log shows this:
waterfox_pjUL6FKIzF

:0:0 ResizeObserver loop completed with undelivered notifications.
03:09:42 – (FEHLER) components/system_log/__init__.py - Die Nachricht ist zum ersten Mal um 02:56:33 aufgetreten und erscheint 3 mal
Unable to include file /mnt/dietpi_userdata/homeassistant/dwains-dashboard/configs/more_pages/pi_hole_page_blueprint/page.yaml: [Errno 2] No such file or directory: '/mnt/dietpi_userdata/homeassistant/dwains-dashboard/configs/more_pages/pi_hole_page_blueprint/page.yaml'
Error fetching ipp data: Invalid response from API: Error occurred while communicating with IPP server.
03:00:02 – (FEHLER) Internet Printing Protocol (IPP)
Config entry 'LG webOS TV E0C8' for homekit_controller integration not ready yet: Timeout while waiting for connection to device 192.168.0.20:44602; Retrying in background
02:52:30 – (WARNUNG) config_entries.py - Die Nachricht ist zum ersten Mal um 02:52:10 aufgetreten und erscheint 2 mal
Setup failed for default_config: (DependencyError(...), 'Could not setup dependencies: cloud, mobile_app')
02:52:00 – (FEHLER) setup.py
Unable to set up dependencies of default_config. Setup failed for dependencies: cloud, mobile_app
02:52:00 – (FEHLER) setup.py
Setup failed for cloud: Unable to import component: IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE! Importing the numpy C-extensions failed. This error can happen for many reasons, often due to issues with your setup or how NumPy was installed. We have compiled some common reasons and troubleshooting tips at: https://numpy.org/devdocs/user/troubleshooting-importerror.html Please note and check the following: * The Python version is: Python3.9 from "/home/homeassistant/.pyenv/versions/3.9.15/bin/python3.9" * The NumPy version is: "1.23.1" and make sure that they are the versions you expect. Please carefully study the documentation linked above for further help. Original error was: libcblas.so.3: cannot open shared object file: No such file or directory
02:52:00 – (FEHLER) setup.py - Die Nachricht ist zum ersten Mal um 02:51:54 aufgetreten und erscheint 2 mal

It seems I am alone with this issue on DietPi, at least I could not find something about it here.
Before the update my HA installation was quite vanilla.
Can I fix this manually or should I wait for an update?

Thanks and best regards,
Hyper

There are couple of issues on your log.

Some sounds similar like an issue we had on the forum last days. Can you check if following is going to help? After the update Homeassistant & MQTT broker integration broken - #18 by Joulinar

You are running 64bit or 32bit system?


Another issue is with your TV as it is not reachable


And some PiHole dashboard seems not to be working

1 Like

That fixed everything!! Thanks :grinning::grinning:

@HyperCriSiS
could you still answer the question what system you are eactly runnning?

@MichaIng
FYI - maybe something we need to look into

The libatlas3-base (without dev sufficient) is required for latest numpy from piwheels, i.e. 32-bit ARM systems: piwheels - numpy

We need to check whether it is used in plain HA already or by a specific integration.

1 Like

It is a 32bit system.

In the mobile app, the dark theme is not applied anymore. Only in Preferences → Mobile App.
As I found out, this is the issue of an outdated WebView:
https://github.com/home-assistant/android/issues/2985

1 Like

But this is not something we could influence, I guess.

No :slight_smile: I just wanted to mention it if somebody else has the issue.

1 Like

ok we will investigate 32bit if we need to add libatlas3-base as dependency

Solved with: v8.11 · MichaIng/DietPi@23910ee · GitHub

1 Like

How can I add theme support btw?
So strange that the Hassio devs do not enable this by default.

HACS downloads them to dietpi-userdata/homeassistant/themes
I tried to access this as mentioned here:
https://community.home-assistant.io/t/default-config-friendly-method-of-enabling-themes/124936/13

If I understand it right, the folder HACS uses is wrong and the themes folder should be in a subfolder?

Just follow these steps: Initial Configuration | HACS

1 Like

Yes, sorry got it now, the info in this thread was too old. The / in the path was the issue. Thanks!