Home Assistant install problem

Installing Home Assistant on A PiW dietpi 6.26.3 took about 1.5 hours. When I try and run it I get

root@DevPi:~# journalctl -f -u home-assistant
– Logs begin at Thu 2016-11-03 17:16:43 GMT. –
Oct 19 15:42:32 DevPi systemd[1]: Started Home Assistant (DietPi).
Oct 19 15:42:36 DevPi homeassistant-start.sh[450]: pyenv-virtualenv: prompt changing will be removed from future release. configure `export PYENV_VIRTUALENV_DISABLE_PROMPT=1’ to simulate the behavior.
Oct 19 15:43:38 DevPi homeassistant-start.sh[450]: Fatal Error: Unable to create library directory /home/homeassistant/.homeassistant/deps
Oct 19 15:43:40 DevPi systemd[1]: home-assistant.service: Main process exited, code=exited, status=1/FAILURE
Oct 19 15:43:40 DevPi systemd[1]: home-assistant.service: Unit entered failed state.
Oct 19 15:43:40 DevPi systemd[1]: home-assistant.service: Failed with result ‘exit-code’.

I installed it as root and I run it as root. I tried creating the deps directory but just get other permission errors. I have not installed Home Assistant before.

just allow the folder permission for home assistant

DietPi:~# chown homeassistant:dietpi /mnt/dietpi_userdata/homeassistant/

It take quit lots of time to start for first time…

Hi guys,

many thanks for your reports. Indeed since we do not overwrite the whole /mnt/dietpi_userdata permissions anymore after every dietpi-software (re)install run, some missing permissions slipped through. Perviously that dir hat dietpi:dietpi 775 permissions, so homeassistant user had access since it is member of dietpi group. However actually dietpi itself does not require write permissions to that config dir, right?

So it should be safer to change ownership to homeassistant user + group. This is what I just implemented: https://github.com/MichaIng/DietPi/commit/4f121c1a5073b76f424fdd6bc697226c12f3e9a6
Do you agree?

Changelog: https://github.com/MichaIng/DietPi/commit/f0f6425556b111e5b7568745b5e3cf378ff2169d

Sorry for the delay in replying broadband was down and had to reinstall HA. That has work it’s now running. Thanks.