Headphone audio RPi Zero 1

Running as headless from a fresh install of Bullseye. DietPi v8.14.2. Not able to see aplay -l recognise the headphone audio device when configured from dietpi-config. Tried another install and the same result.
Is headphone audio working on headless?

With HDMI monitor connected aplay -l shows the expected

aplay -l

List of PLAYBACK Hardware Decices
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 8/8

aplay -L

Discard all samples (playback) or generate zero samples
bcm2835 HDMI 1, bcm2835 HDMI 1
Direct hardware device without any conversions

Thanks for any comments.


I think you need to turn on audio output enable

Getting Started With Dietpi and the Dietpi-Config Tool (singleboardbytes.com)

System Configuration - DietPi.com Docs

I did amend the boot config to dtparam=audio=on if that’s what you meant.
I had pcm audio running on diepi 3 years ago using the GPIOs and an RC audio filter.
Haven’t been able to get pcm GPIO audio working on latest dietpi release. I’ve switched solutions to using a cheap usb audio dongle, mpg123, paho-mqtt and running a python script at startup using venv and it works well and was easy to do. Thanks