Headless Install - Light Blue Screen / No Icons - RasPi 3B+

Hi All - Total n00b when it comes to RasPi/DietPi. I have a headless RasPi 3 B+ on DietPi (v6 - Buster) and trying to connect via RDP from Ubuntu Bionic Beaver (18.04.3 LTS) using Remmina.

I successfully connect, see the XDRP logon window, input my password and then nothing. Just a light blue screen, no icons, etc.

I’m sure this is something silly, but can anyone provide some feedback on what I might be missing? I also tried to do it using TightVNC, but Remmina gives me a “unknown authentication scheme from vnc server” error.

Appreciate any input or assistance in advance.


I have good experience using RealVNC Server on my headless RPi. It’s working quite well with my Windows Client. As far as I can see, RealVNC is offering a Linux Client as well that supports Ubuntu 18.04 LTS

Edit: I quickly installed Ubuntu 18.04.3 on a VirtualBox as well as RealVNC Server on my RPi3B+. As soon as Ubuntu was ready, I download the RealVNC client and it was working OOTB.

Do you have a shell only install on the RPI? Or did you install a light desktop package (aka desktop environment)?

XFCE works great…there are TONS of howto’s on how to get VNC working, but if the headless RPI doesn’t have a desktop environment installed VNC in won’t work.


The digitalocean howtp’s are usually spot on!

I manually start the vnc service and shut it down to free up the ram the desktop environment uses when it loads for remote access


usually I just install RealVNC Server from dietpi-software. It brings all needed packages. No need to install anything in addition.

well, try uninstall then re-install, if the packages are imported thru the dietpi installer then it should work

All - Thank you so much for the input! I installed the desktop pack and enabled at boot, but no avail. Then I ditched Remmina. I installed tightvnc server on the pi and then vnc client on Ubuntu. Initially it wouldn’t work with just the IP of the Pi, but once I specific port 5905 it worked! So nice to be out of command line :sunglasses: Thanks, all!