HDMI audio not working in bookworm

I have installed DietPi v8.7.1 on a Raspberry Pi 4. I am using an HDMI monitor.
After installing pulseaudio and the PulseAudio Volume Control, the HDMI Digital output device does not appear and there is another Analog Output device where HDMI should be. The Headphones output is present.

The HDMI device does appear in ALSA:
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
I can play a wav file on it using aplay and paplay.

After installing rtaudio-5.2.0 from source, I ran the tests. The “Analog output” that plays through HDMI audio did not work. The error is
PulseAudio device does not support output.
The headphone output does work.

They both work correctly in DietPi bullseye upgraded to v8.7.1.


Is there a specific reason for using PulseAudio? Did you try to purge it again and setup audio via dietpi-config?

Some packages such as GNU Radio are using Pulse. Removing Pulse wants to uninstall GNU Radio.
I build Software Defined Radio systems and some of the applications use Pulse, some use ALSA.
I find that special functions like a virtual audio cable are easier in Pulse.

I do not find any way to install Pulseaudio in dietpi-config. There is no install option in dietpi-software.

I did play with the Sound card options in dietpi-config, but I was trying to get the HDMI device to say HDMI in the Pulseaudio control panel, but that did not help.


Ah, another reason to not use the Debian package but pip. Generally it should be able to use an ALSA device directly without PulseAudio.

I have no experience with PulseAudio, so cannot help with this, but you should be able to select HDMI audio via dietpi-config regardless, which effectively disable analogue/3.5mm audio firmware wise. So PulseAudio should only see one audio device: HDMI.

I was not aware that pip could install GNU Radio.
wiki.gnuradio.org does not cover installing gnuradio with pip.
What is the command line?


When I switched Sound card from auto to hdmi using dietpi-config, the Analog entry that had been using HDMI disappeared, leaving only the headphones device.
It is strange that enabling analog makes HDMI work, although labeled Analog.
Some of my applications do not use GNU Radio, but I believe it can use ALSA.
My applications that use ALSA do work.
RTaudio tests only work with the latest version installed from the github source.
Pulseaudio basically works now.
Although we can expect problems with a pre-release system, we want to help fix them.

I gave it a hard test tonight. I was receiving FT8 signals with CubicSDR, sent to WSJT-X for decoding and displayed them on a map with GridTracker. At the same time, I received SSB signals with CubicSDR. The CPU load was at least 95% and it handled it well with only rare audio dropouts.