Having trouble logging in a user Rock4SE

I am having trouble logging in as my user. I created my user with password, but cannot log in as user through lightDM or ssh.

During first-run, I could not log in as user dietpi with password dietpi. I was able to log in as root. I changed the root and dietpi password after initially logging in as root. I can log in as root with new password, but cannot log in as dietpi. I deleted user dietpi and created a new user, but cannot log in as the new user either. I enabled autologin for my user and it functions as it should. Logs me in as the user, but I still cannot log to terminal or ssh as my user.

Any ideas?

Creating a bug report/issue

Required Information

  • DietPi version: V8.a5

  • Distro: Rock4SE from Radxa website

  • Kernel version | Linux DietPi 5.15.93-rockchip64 #23.02.2 SMP PREEMPT Fri Feb 17 23:48:36 UTC 2023 aarch64 GNU/Linux

  • SBC model | Rock 4SE

  • Power supply used | 12V

  • SD card used | PNY Elite 64G

Additional Information (if applicable)

Fresh install

  1. Fresh install
  2. Attempt to login as dietpi - password dietpi
  3. Create new user
  4. Attempt to login as new user - new password

Expected behaviour

Should log in as dietpi or new user

Actual behaviour

error message - incorrect password

Extra details

I installed account-service, but still no joy.

Never mind. Assuming I did something wrong, and not being too far into this project, I decided to try a fresh install and start over.

Reinstall worked. Apparently I screwed up the previous install.