Gtk latet is not installable on my RPI400 with dietpi system latest on it? 64bit version


I am not sure whether the topic was already discussed btut in this case i created it for being sure it is answered on.

i have dietpi installed latest and did already a loads of onfiguring that woked out of the box
BUT the problem with GTK installling still gives the command that there are no packages to be found. although the list of gtk3 depencies they are installed but gtk 2.0 is the version that gives conflict wiht installing the new programme that i need: the belgian eid middleware. it keeps stopping installing not having found gtk3.0

but when i try apt-get to do install the complete gtk environment there is no pakage to be found.

nnow i dont know anymore what to do? can you help me to get gtk the newest version being installed normally? i love codeline to be sure i dont make mistakes.

hoping on quick and decent answer comming with a solution that works out of the box.
kind regards
Wim Pauwels

Just to avoid any misunderstanding, DietPi don’t have an onw apt package repository. We use the global Debian one. Means your package would need to be available there. Or you add an additional repository that is going to ship the package in question.

hi i am right here already read your reply but i installed it with apt-get install gtk even with gtk* but nothing is being found

now i can do a reinstall because my system is probably messed up with it al the dependencies that have the missing platform of main packages gtk;

i do understand your saying but i also noticed in any ubutnu install that i neeeded to do the gtk install right before any application install so to avoid it makes corrupted files like i am now having the trouble.

i am posting on another system now to you but i am hoping i ccan restore it from te start again.
is there a good repository to try first with getting the installation of GTK done before i reset my installation of dietpi in the whole hard disk?

kind regards
wim pauwels

DietPi is based on Debian and not Ubuntu. Have a look to vendor information on how to install gtk The GTK Project - A free and open-source cross-platform widget toolkit

i already found that site myself but where to look for the right packages because it looks that debian/ubuntu packages for installing are the same repository linked in GTK mirrors?

Debian/Ubuntu libgtk-4-1 libgtk-4-dev gtk-4-examples

i will try the lib gtk-4-1 perhaps i didn’t try that package already in diepti.

but is it also necessary to install all the meson buid seperated needed packages that are mentioned in the first section of the page? because that was also something i tried but more depencies were not found either. i gonna reboot now the other system again and try again but i dont really see the good solution of it. You can ceartainly already answer in the meantime if i am doing somethin stupid with it.but i am gonna try now

kind regards till quickly
wim pauwels

Packages are libgtk-4-1 and libgtk-4-dev for development. If you facing issues, contact gtk support and ask them on how to install on Debian.

i now have not many documents on the dietpi system i gonna do a reiinstalll and then without any software envrionment i am gonna install gtk latest on that new install and i remember that he cant find any other version that comes with other packages.

so firtsly gonna do that because i tried to add the right repostory link to the packages list but it doesn’t work. I could try to send you the logfile of trying alll gtk related commands but that would lead us to far for discussion. and more with the reading of it it complains too much on that gtk problem. bacause i knew when i tried to install Beid middleware the package in question that needds gtkk3.0 or higher and when i tried the config of it every libpackage was not able to install anymore. because it recquires a basic gtk configuration with all dependencies of it before you can the configuring build with meson of the beeid packages. so please give me a little time now i will contact you when i succeed in the right order of installations. i can read your answers through my mobile phone ofcourse so we can continue talking when installing.

till soon
kind regards
Wim Pauwels

hey i am very happy to be able to tell you that a new installation of the os no matter which one debian or u untu or any distro that you would think of ALWAYS ASKS TO INSTALL THE GTK AND ALL LIBRARIES COMING WITH THE INSTALLATION THROUGH APT GET INSTALL THEY WILL ALWAYS BE NEEDED TO RUN RIGHT AS ROIT AND AS THE BEFOREHAND S INSTALKATION PROCEDURE OF ANY OTHER PACKAGE OR PROGRAMME. Sorry for the caps that i used here. But by doing it like i say now tge other installations work like a charm now. Its somehow weird because why does the debian version of dietpi not ship all gtk needed libraries in the firstplace? It would come in handy anyways. But that is another issue isnt it? . anyway i am happy to see everything is working now. So this topic canbe closed.
Anyway for every system that people install: first install as the root the gtk gtk+ and other gnu compilers and c+ and gcc … As the root before trying any programme installation in the terminal. That will be the very only way to install everything tbe right way without any liberrors.

Thank you for helping me out with trying again some things.

Have a nice day
Kind regards
wim pauwels

Just to avoid a misunderstanding. There is no DietPi version of Debian. It is Debian. And all software package installations working same way as on other Debian system. There is nothing special. And why we don’t have all libraries / dependency installed right from the beginning? Well, that’s what our project is aiming for. To provide as minimal image as possible. Means we ship our image with less pre-installed packages compare to plain Debian or Raspberry OS. That’s why we call our project DietPi.

Next, I doubt gtk is a software package that would be needed by a larger number of DietPi users. I guess 99% of our community even don’t know what gtk is. For development system, we offer a software package Build Essentials (ID 16). It contains some build tools and can be installed from our software catalogue directly.

1 Like