Governor powersave.. But it isn't true!

Hello everyone!
When the cpu of my Rasberrypi3 warms up (I use it as a cloud server with nextcloud), the frequency drops to 600 MHz (ondemand governor) and that’s ok. The problem is that the frequency then no longer rises up and all the clients give me “connection refused”. I’ve checked with the command “cpu” and I find that the governor is “power save”, but if I go on dietpi-config me it correctly displays ondemand. Sometimes if I turn off (not restart, really poweroff) and power back up, Rpi3 start properly. But most of the time remains at 600 MHz even if the temperature is low with the governor powersave and nothing works (always connection refused, I can only use ssh, nothing else).
I’m asking for help because I don’t really know what to do …
Thanks in advance and sorry for my poor English, I hope you can understand my problem :wink:


Please take a picture/screenshot of this command:


What ever the above CPU gov shows you is pulled directly from kernel. Thats whats running.

I think its either overheating causing the CPU clocks to reduce, or, you have a script/service that might be changing the CPU governors during boot.

I do not understand by what logic, sometimes it restarts with powersave governor, sometimes with ondemand, but always at 600 Mhz. At this rate I can’t do anything, I alwayes obtain “connection refused” except when I get into ssh (port 22).


Yep, that is bizarre lol.

I’d like to see your system config, something might be amiss, can you please send us a bug report:

I tried several times but it appears to stop responding at the same point (output_8.txt at 71%) every time. Sigh.

Ok, other detail about my investigation:
When my RPi3 boot in 600MHz it can’t send bugreports, just tried several times (I wrote it in the last post).
I tried to restart it several times (sudo reboot), no changes. Always 600 Mhz.
Then I send “sudo poweroff”, turn off the power, removed microusb, reattached it after a few minutes: RPi3 starts at 1200 MHz (as it should be).
Try again to send the bugreport: it works! :roll_eyes:
And, of course, also other connections work (in 1200 MHz). When it boot in 600 Mhz, I repeat, I can only make SSH connection (all the rest is “connection refused”). :thinking:
Schermata 2016-12-10 alle 23.28.15.png

Hi Didi,

The command run prior to compression is below, please try running this command manually to see if it hangs.


When my RPi3 boot in 600MHz it can’t send bugreports, just tried several times (I wrote it in the last post).

I cant seem to find the bug report you sent, not appearing on our system. Sorry about that, could you please try sending another bugreport?

Also, which Power supply are you using with the device (eg: 5v/2A Samsung charger)?

I retried: can you take a look for Reference Code c0c30049-b1c7-4042-995f-c1e6ebae12ec-0, please? :slight_smile:
My Power Supply is a Vilros Adapter (2500mA). I thought of a undersize (or rather, to a hardware defect), but my RPi3 doesn’t start at 600Mhz every time, sometimes is OK (1200 or even overclocked). It seems a software problem, not hardware… I don’t understand :frowning:

Yep, worked this time, thanks. I’ll take a look at get back to you.

If it can help, cpufreq-info tell me

current policy: frequency should be within 600 MHz and 1.30 GHz.
The governor "ondemand" may decide which speed to use within this range.
current CPU frequency is 600 MHz (asserted by call to hardware).

I continue to investigate until I wait enlightened opinions :rofl: