Got stuck during first install of DietPi


i’m trying to install DietPi from a fresh download (x86_64/Bookworm/BIOS-version) but can’t finish installing it.

Tried several times but DietPi install process stops every time after initramfs (see picture).

Hardware is x86-PC (BIOS), Lenovo X220 Laptop with i5-CPU, 32 GB RAM, 500 GB SATA-SSD with Kubuntu 20.04 pre-installed. Laptop boots without problems when starting Kubuntu so i guess no hardware problems here.

Do you have any ideas how i can solve this problem and get started using DietPi?

how did you install DietPi image? to your HDD?

Hi, sorry for missing that.

I downloaded and unpacked the archive with Ark on another Kubuntu machine (Home-PC). Install is from an USB-Stick which was prepared/made bootable with Ventoy (

Plan was to install DietPi on the SSD on my X220-Laptop.

did you used the installer image?

usually the iso to be flashed on a USB stick. Once done, you can boot of the USB stick and follow instructions to flash image to SSD

Thank you very much for your very quick reply… :slight_smile:

I downloaded the first image from here:

After unpacking it i had the DietPi_NativePC-BIOS-x86_64-Bookworm.img on my stick which caused me the problem described in my initial post.

After that i downloaded the which worked fine after unpacking and putting it on the USB-bootstick.

Did the same with like you advised me to. This one also worked well and installed DietPi without problems.

Looks like my problem is solved. Thanks again for your quick help.