Google AiY

Hello,

I tried to install the Google AiY on my setup but it fails.
I’m using Raspberry pi 3b+
Dietpi 6.21
at the end of the installation I got a red message :
“google-api-core 0.1.4 has requirement requests<3.0.0dev,>=2.18.0, but you’ll hav e requests 2.14.2 which is incompatible.”

Googeling I tried a suugestion found at https://github.com/google/aiyprojects-raspbian/issues/355
/mnt/dietpi_userdata/voice-recognizer-raspi/env/bin/pip install requests==2.18.4
I got another red message:
“google-assistant-library 0.0.3 has requirement requests==2.14.2, but you’ll have requests 2.18.4 which is incompatible.”
and then cd src && …/env/bin/pip install .
nevertheless I tried to register but it failled : :cry:
Enter the authorization code: xxxxx
[2019-03-13 18:10:58,024] INFO:root:OAuth credentials initialized: /home/dietpi/.cache/voice-recognizer/assistant_credentials.json
Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python3.5/threading.py”, line 914, in _bootstrap_inner
self.run()
File “/usr/lib/python3.5/threading.py”, line 862, in run
self._target(*self._args, **self._kwargs)
File “/mnt/dietpi_userdata/voice-recognizer-raspi/src/main.py”, line 66, in _run_task
with Assistant(credentials, model_id) as assistant:
TypeError: init() takes 2 positional arguments but 3 were given

Any tricks ???
Thank you
Jean

bricolodu13
Many thanks for your report. I never had a look into our Google AIY install code, which means it has not been touched for a long while and things might have changed, making it incompatible.

I will try to replicate and update our installer as required. But this will not do it into v6.22 anymore, which is already in late Beta stage.

Anyone has Google AiY up and running?

I followed directions here. But need advice on troubleshooting. Seems everything installed, migrated assistant.json, but I never got to Ok Google prompt… Help? :slight_smile: