Gitea fails to start after latest update

I had Gitea working on a prior version of DietPi but recently reinstalled (DietPi v6.26.3) to find it no longer will start.

sudo systemctl status gitea
● gitea.service - Gitea (DietPi)
   Loaded: loaded (/etc/systemd/system/gitea.service; disabled; vendor preset: enabled)
   Active: failed (Result: signal) since Wed 2019-10-23 15:09:54 NZDT; 5min ago
  Process: 944 ExecStart=/mnt/dietpi_userdata/gitea/gitea web (code=killed, signal=SEGV)
 Main PID: 944 (code=killed, signal=SEGV)

Oct 23 15:09:54 pi-git systemd[1]: Started Gitea (DietPi).
Oct 23 15:09:54 pi-git systemd[1]: gitea.service: Main process exited, code=killed, status=11/SEGV
Oct 23 15:09:54 pi-git systemd[1]: gitea.service: Failed with result 'signal'.

The error (running directly) is

/mnt/dietpi_userdata/gitea/gitea web
Segmentation fault

Not sure what else to include to help with troubleshooting…

Many thanks for youre report. From which DietPi version did you upgrade? With v6.24 => v6.25 we did a Gitea reinstall indeed, but v6.25 => v6.26 did not touch it.

Which SBC/device do you use?
Please try to simply reinstall it: dietpi-software reinstall 165

Working version was a clean install of v6.25. That device got re-purposed and I had to stand up a new RPi3 and failure occurred when clean installing v6.26 (which now doesn’t make sense given you didn’t change anything).
Have just tried dietpi-software reinstall 165 and it is still not starting (same status error). The pi is not doing anything at the moment so more than happy to try any suggestions/clean install etc. if anyone has other suggestions

Ah found the issue, indeed a bug our side since we do not reset /mnt/dietpi_userdata permissions on reinstalls anymore. Please do:

chown -R dietpi:dietpi /mnt/dietpi_userdata/gitea

Resolved with:

Fantastic, thanks for following up on this…

@MichaIng sadly this doesn’t resolve the segfault in my case (RPi4, fresh install of 6.26).

It appears to be related to since uname -r gives 4.19.75-v7l+ on my pi.