Getting the auto install working

Creating a bug report/issue

Required Information

  • DietPi version |

  • Distro version | bullseye 0

  • Kernel version | Linux ControlNode1 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux

  • SBC model | RPi4

  • Power supply used | 5V 2A

  • SD card used | Samsung 32GB

Steps to reproduce

  1. copy img of DietPi to USB
  2. add dietpi.txt
  3. boot

Expected behaviour

Auto setup should finish and install everything

Actual behaviour

On first log in, I get screen that the installation state in inconsistent and if I want to take over.

Extra details

I take over the installation process, continue without issue… except I need to manually confirm some boxes…


Welcome to our community. How long do you wait before trying login via SSH? On first boot it could take a while to update all packages and finish installation. Are you able to attach a screen to check where installation stuck? One thing I have seen in your config file. The value CONFIG_G_CHECK_URL_TIMEOUT was incorrectly set.

This is your value


but ist should be


without the s. at the end.

Hello @Joulinar that would explain this error message I found in log:

/boot/dietpi/dietpi-survey: line 128: 10s: value too great for base (error token is “10s”)

Going to change it and give it a try again.

@Joulinar hmm that was not it.

Waited way longer than it normally need to finish, but no luck, still getting:

[FAILED] Unknown install state/First run setup failed on another screen (PID=1158).

Issue solved.
I have changed these:


After this it worked, although I think it was the attempts, 2 were not enough…

Usually 2 attempts are fine for majority of user. But yeah, sometimes it takes a while longer. :smile:

I should have thought of attaching a monitor, but when I made my rpi chassis I did not think it would be needed, :slight_smile: so maybe on v.3.0 I make more space :smiley: Imgur: The magic of the Internet but can confirm 3Pis already setup and going fine.

1 Like

uh wow, what is the scenario you are going to use it for? looks like some kind of “cluster”.

Yes Kubernetes cluster, I had it as a test of OpenFaaS platform and some coding. Also my old project to screenshot every .sk domain and analyze what are the dominant colors for our internet ( yes I was very bored that time :smiley: ) . And some other solution that require multiple worker setup/web scraping etc…

I’m in process of rewriting my Kubernetes guide since finally this chassis is ready, and jumped from Ubuntu to DietPi as somebody suggested it in comment. At the time of making 64bit version was not avalible, but it is now… thats how I ended up here :smiley:

I guess I need something like this chassis for my test lab :rofl:

I hope I can release the chassis with all the 3d printed parts and some guide soon. It’s in testing phase now… Kind of waiting if it catches fire or something. :smiley: Need to finish rewriting the guide, then collect cost for all the of the shelf parts, write guide for assembly etc… so “soon™” :smiley: