Getting Raspberry Pi Camera working with Compute Module

Hello Everyone,

I’ve been using DietPi for a while now with the raspberry pi and now have moved on to the compute module 3. I’m trying to get both camera 0/1 working on it, however, I am having no luck. I’ve been following this tutorial:

I still receive the typical ‘failed to create the camera component’ message with either cam0 or cam 1. I have the IO jumpers in place. I have tried 3 cameras (2 V2.1 and 1 v1.3). The only thing I can think of is the location of the file “dt-blob.bin”. I know that the default folder locations, especially for files loaded at boot, is structured differently with DietPi. What would the proper location of the “dt-blob.bin” file be to be loaded at boot? Right now it is /boot/dt-blob.bin.

Hi Nate,

Unfortunately, I do not own any CM modules yet, so I’am unable to test this myself.

Ok, so the /boot/dt-blob.bin location is correct. DietPi only moves /boot/config.txt and the dietpi scripts there, to RAMdisk during boot. /boot/dt-blob.bin would be untouched.

Are you testing the camera with? May provide more info:

raspistill -o cam.jpg

OK, good, I first wanted to confirm the /boot/dt-blob.bin location was correct. My friends over at the raspberry pi forums have been helpful to verify the dt-blob.bin file has been loaded wit the ‘vcgencmd get_camera’ command:

I think my issue is likely related to memory allocation for the gpu and I am also using the wrong dt-blob.bin file.

OK, looks like everything worked just like the normal Raspian distribution. My issue is my Cam1 port is damaged on my IO board and I wasn’t using the dualcam blob so cam0 wasn’t conifgured. I at least have itworking on cam0 now.

Hi Everyone,

I’m bumping this because as it turns out I was wrong. I’ve tried 4 different cameras and cables, 2 different camera adapters and cables, 2 IO boards, and 2 Compute 3 Lite modules. No luck, no matter what I can’t get cam1 working. I’ve had a post going on for a while over at raspiforums:

I’m now at the point where I need to switch to a fresh Raspian Jessie install.

Just tried the latest raspian jessie image and as it turns out cam1 does work, but for some reason with DietPi it does not. I’m wondering if it has something to do with how i2c-1 is recognized. I have seen i2c-1 is in the device list and used i2c-tools to detect 0x10 and 0x64 on the i2c-1 network, but maybe for some reason at boot it isn’t up yet?