G_Ether for USB with Dietpi on Pi Zero?

I wanna get this working after getting a few Pi Zeros at microcenter. Is there a way to do this on Dietpi?

Hi,

hmm, please what is “G_Ether” ?

Gigabit Networking? Like this? http://www.jeffgeerling.com/blogs/jeff-geerling/getting-gigabit-networking

If so, yes.

Virtualized ether net over USB.

Then how do I set it up?

any update?

Try:
https://gist.github.com/gbaman/975e2db164b3ca2b51ae11e45e8fd40a

That’s what I was referring to. But when I attempt to use that bootline, it doesn’t seem to load the module (g_ether) last I tried.

On a running DietPi system, you have to edit:

nano /Dietpi/config.txt and add:

## for USB Ethernet driver
## Open up "/boot/cmdline.txt" and add "modules-load=dwc2,g_ether" after "rootwait"
dtoverlay=dwc2

as well. If you edit SD-Card in a card-reader on your host computer, you have to edit:

  • Open up the “boot” partition and edit “config.txt”, adding “dtoverlay=dwc2” to the bottom
  • Open up “cmdline.txt” and add “modules-load=dwc2,g_ether” after “rootwait”

After restart have a look in dmesg

[    5.194515] g_ether gadget: Ethernet Gadget, version: Memorial Day 2008
[    5.195979] g_ether gadget: g_ether ready
[    5.197409] dwc2 20980000.usb: dwc2_hsotg_enqueue_setup: failed queue (-11)
[    5.201958] dwc2 20980000.usb: bound driver g_ether
[    5.389216] dwc2 20980000.usb: new device is high-speed
[    5.481414] dwc2 20980000.usb: new device is high-speed
[    5.518094] dwc2 20980000.usb: new address 31
[    5.574640] g_ether gadget: high-speed config #2: RNDIS
....

… and have a look at: https://dietpi.com/forum/t/raspberrt-pi-zero-usb-device/1160/2

pi@RPi-Zero-W_Radio:~ $ ifconfig usb0

usb0      Link encap:Ethernet  Hardware Adresse 5a:a6:ce:db:b8:8f
          inet Adresse:192.168.7.2  Bcast:192.168.7.255  Maske:255.255.255.0
          inet6-Adresse: fe80::58a6:ceff:fedb:b88f/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:288 errors:0 dropped:0 overruns:0 frame:0
          TX packets:280 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:20557 (20.0 KiB)  TX bytes:75423 (73.6 KiB)

… and from now on never again use dietpi-config ==> Network to change your network settings

hi all i have zero pi

i add
“config.txt”, adding “dtoverlay=dwc2” to the bottom
and add “modules-load=dwc2,g_ether” after “rootwait”

also add ssh file on sd card

but nothing work

its wordk fine on Raspbian