Freshly downloaded RPi4 image not booting

Creating a bug report/issue

Additional Information (if applicable)

  • Software title |
    DietPi install image for RPi4

  • Was the software title installed freshly or updated/migrated?
    Fresh install

  • Can this issue be replicated on a fresh installation of DietPi?

Steps to reproduce

  1. …Downloaded most recent DietPi image for RPi4
  2. …SD image created with Etcher.

Expected behaviour

  • …Should be dumped into SSH session on initial boot

Actual behaviour

  • …System hang

Extra details

  • …Red LED is on, green LED on briefly
    -…Armbian install on same RPi running without issues

Can you connect a screen and check where it stuck

No screen available but I had a similar experience with a nanopi image recently and I note a similar issue was also reported for the Asus Tinkerboard image.

Michalng may have an idea what may be happening across the images since he was able to help with the faulty nanopi zero download

Usually, the images should be working fine. Which image did you used exactly? Because we offer 3 different RPi images.

The 64-bit image I guess, now that we split downloads by RPi models.

The issue with ASUS Tinker Board and ZeroPi is unrelated and solved.

Based on what you say about LEDs, it seems to boot fine but most likely fails to establish a network connection. Without screen or serial console output, it will be hard to help. Do you see the RPi as DHCP client in your router and/or are you able to ping it?

Two days ago i was testing my tv hat and image for RPi4 was booting fine.

1 Like

I used DietPi_RPi-ARMv8-Bullseye image both on SSD and SD card. As I’ve said an Armbian image worked without issue.

Michalng, the RPI does not appear in DHCP nor can it be pinged

As of the amount of daily RPi image downloads, a general issue with the image can be ruled out. To know more, as said, boot messages are required.

You have or attached via Ethernet and didn’t change dietpi.txt settings, right?

Do you have any other peripherals attached, e.g. USB drives/devices?

A better comparison with our image is btw the official Raspberry Pi OS 64-bit. Armbian uses a different kernel.

Just did a test with 64bit image. No issue at all. Working perfectly fine.

Perhaps a bit more history may assist. At some point I had uninstalled the WiFi drivers in my DietPi installation and recently attempted to re-enable wireless. The system crashed during the process, would not boot and a re-installation of a fresh image failed as above.

Upon your suggestion I grabbed the official RPi 64bit lite version and installed without issue. After, I used (Other Device) beta script and RPi was fine.

At least from our side we are not able to replicate the behaviour. A new download image is fine on my demo RPi4.

My luck :wink:

Appreciate the time taken to help troubleshoot and grateful for the work done to create/maintain DietPi.

maybe you can try a different usb pen stick or SD card. I use Rufus to write the image.