Fresh installation of DietPi not automatically obtaining an IPV6 address

I’ve got a fresh installation of DietPi running on a Raspberry Pi 4. It doesn’t seem to automatically obtain an IPV6 address from my router.

Trying to ping 2600:: gets me the error “Destination unreachable: Beyond scope of source address.”

A fresh installation of the latest version of Raspberry Pi OS is able to retrieve an IPV6 address, so I’m assuming that something is different in DietPi’s networking. I was hoping one of you might have an idea of what may be going wrong.


Did you enabled IPv6 on dietpi-config network settings? Can you share following

ip a

Usually there is nothing special on DietPi as we use Raspberry OS as well for our image. Personally I have als my DietPi device using IPv6 without issues.

Do you use DHCPv6? Most common is letting LAN hosts and the router auto-configure IPv6 addresses based on MAC addresses and public IPv6 prefix via SLAAC. DHCPv6 is used or reasonable in rare cases only and not used on DietPi by default. If you want to use it we can share an ifupdown drop in config to enable it for the network interface.

I have to admit that I don’t know what DHCPv6 is. My networking knowledge is limited.

If it’s something that is out of the ordinary, then probably not. I’m just relying on my router to hand out IPs.

It’s intended and right that you connect via WiFi and that the LAN IP range is

The WiFi interface has no other IPv6 address assigned than the LLA (local-link address) which it applies to itself based on the MAC address. The next step of SLAAC would be that it receives a router advertisement to deal out a GUA (global unicast address) which can be used to connect to it and allows it to connect to the Internet via IPv6 as well. As this does not happen, it seems that the router does not send out IPv6 router advertisements, or the DietPi system for some reason does not receive them. Connection to the WiFi AP is up and you can successfully connect via IPv4 to this DietPi system?

Yep, WiFi over IPV4 is working fine. I’m using the Pi over SSH. I may try manually assigning an address if I’m able to figure that out.

Check the router settings whether IPv6 router advertisements are enabled for WiFi. You may also check the DHCPv6 settings in the same turn, if provided by the router. A manual IPv6 address may not work if the public IPv6 prefix changes.