Fresh installation Odroid C1+ - eth0 error


I have run into some issue, I have found a similar issue in the past but it was with the V64is version. In a short, DietPi founds my ethernet as eth1 instead of eth0 and it prevents it from getting a LAN connection, which is annoying as it is intended to run heedlessly.

Basically after flashing my SD Card my Odroid lunches, but during the boot it gives me the info that there is eth1 present and ignores it.
After the boot is finished I can see on my screen only the basic info with V144 version and that:

eth0: error fetching interface information.

Maybe some one much smarter then can point me out on how to get around this issue?


Is the V144 the newest version available for the C1 Odroid?


What is funny that before the first/second reboot after a fresh flashing, during the FS expand and other scripts running the ethernet is working fine.
I was able to see the IP being assigned to it on my DDWRT. Looks like the problems starts after the first auto configuration finishes.


I have found the forum discussion I have mentioned earlier


Yes, what’s correct for Odroid C1. It is eth1 not eth0 after bootup.

Odroid C1 is verry picky with SD card and PSU.

Try another SD card with better Odroid C1 compatibility.

Please don’t use PSU from your mobile phone and crappy china micro usb cable.

Yes, DietPi_v145_OdroidC1-armv7-(Jessie).img is the last at the moment.
But it will be auto - updated to last version (v159) after frist complete boot up and login, if your device have a working internet connection.

 ~# dmesg | grep eth
[    0.767887] ethernet_driver probe!
[    0.771100] ethernetinit(dbg[c09c8080]=1)
[    0.774361] ethernet base addr is fe0c0000
[    0.788374] eth0: PHY ID 001cc916 at 0 IRQ -1 (0:00) active
[    0.791634] eth0: PHY ID 001cc916 at 1 IRQ -1 (0:01) active
[    4.241733] systemd-udevd[261]: renamed network interface eth0 to eth1
[    9.400664] eth1: opened (irq 40).
[    9.411510] ether leave promiscuous mode
[    9.413332] ether leave all muticast mode
[    9.415186] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   13.391376] [adjust link] -> eth: full-duplex
[   13.393165] [adjust link] -> eth: phy_speed <> priv_speed)
[   13.394935] [adjust link -> eth: am_adjust_link state change (new_state=true)
[   13.398516] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

Wow … 2015 :smiley: .

I have never see any DietPi v65 before. :open_mouth:

Thank you for the replay.

Odroid C1 is verry picky with SD card and PSU.

Try another SD card with better Odroid C1 compatibility.

I have tried 3 different SD Cards (SanDisk Ultra microSDHC / SanDisk microSDHC Memory Card / Samsung SDHC EVO ), before posting, happens on all of them, but before DietPi I have been using those SD on the Odroid to boot LibreElec without running into any issues. Anyhow I will buy another SanDisk Ultra microSDHC and try then.

For the PSU I am using the one sold by the Hardkernal, only for the Odroid :

5V/2A Power Supply EU Plug
for ODROID-C1+ / C0 / C2

So unless I am not the unluckiest man on the planet with those SD Cards, then I still don’t know how to fix this one ;/


  • PSU looks good.
  • SanDisk Ultra microSDHC looks good, this one work for me. No fast, but it work. Very old card, found it in the waste bin.

With Samsung SDHC EVO I have some problems to work with Odroid devices.

LibreElec based on JeOS (SUSE), DietPi based on Debian, exactly Debian 8 Jessie maintained by meveric

I have no hassle with SanDisk Extreme PLUS microSDXC, Class 10, U3, V30, A1 with all my devices.

Yes, have tested image DietPi_v145_OdroidC1-armv7-(Jessie).img before posting here, especally for you. It works.

I would suggest:

  • write image to fresh full formated SD card with writing/verification for example with Odroid Improved Win32DiskImager or Etcher or Rufus
  • DO NOT edit dietpi.txt or boot.ini with Windows notepad. Leave it as it is (best solution) or use a unix compatible editor.

Thank you for the post.

I have tried everything mentioned, I have even tried two additional SD Cards, effect stays the same…

Is there any way to get the booting logs so I could look through them or post something here in order for someone willing to figure it out?

Thanks in advance.