fresh install oDroid C1

fresh install of DietPi_v6.0_OdroidC1-ARMv7-Jessie.img onto the eMMC, boots up fine, installs the updates, reboots and then nothing, dead in the water

tried using a SD card, it starts up but nothing else, no updating, no way to update, just get this when i log in

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
sh: 1: /usr/bin/xauth: not found
-bash: /DietPi/dietpi/login: No such file or directory
-bash: /DietPi/dietpi/func/dietpi-globals: No such file or directory

tried a few different programs to write the img to a SD card and eMMC, get the same output whatever i use

Looks like dietpi-ramdisk failed to start.

Could you please paste results of the following:

systemctl status dietpi-ramdisk
cat /var/tmp/dietpi/logs/dietpi-ramdisk.log

sure, here it is, this is from the SD card

root@DietPi:~# systemctl status dietpi-ramdisk
â— dietpi-ramdisk.service - DietPi-RAMdisk
   Loaded: loaded (/etc/systemd/system/dietpi-ramdisk.service; enabled)
   Active: failed (Result: exit-code) since Thu 2018-01-18 20:07:06 GMT; 12h ago
  Process: 555 ExecStart=/bin/bash -c /boot/dietpi/dietpi-ramdisk 0 &>> /var/tmp/dietpi/logs/dietpi-ramdisk.log (code=exited, status=1/FAILURE)

Jan 18 20:07:05 DietPi bash[555]: /bin/bash: /var/tmp/dietpi/logs/dietpi-ramdisk.log: Read-only file system
Jan 18 20:07:06 DietPi systemd[1]: dietpi-ramdisk.service: control process exited, code=exited status=1
Jan 18 20:07:06 DietPi systemd[1]: Failed to start DietPi-RAMdisk.
Jan 18 20:07:06 DietPi systemd[1]: Unit dietpi-ramdisk.service entered failed state.

root@DietPi:~# cat /var/tmp/dietpi/logs/dietpi-ramdisk.log
cat: /var/tmp/dietpi/logs/dietpi-ramdisk.log: No such file or directory


/bin/bash: /var/tmp/dietpi/logs/dietpi-ramdisk.log: Read-only file system

This indicates a filesystem issue, most likely due to insufficient PSU and/or SD card.

For stability, please ensure you are using a 5V/2A official PSU (Odroid or RPi), and a well branded SD card (eg: Sandisk).

ok tried an 8gb sd card and it booted up fine, now i am still stuck on it not booting after updating, sd card and eMMC do the same thing, tried multiple power supplies (universal adapter, 45W 6 port usb charger 2.4A max output) but nothing after being updated