Fresh Install Kernel Panic

hello, so ive been using dietpi since this summer and it was working pretty well. i was running it headless. however, i wanted to:

  1. reinstall using USB hard drive instead of USB pen drive
  2. miniDLNA will randomly loose connection if i dont use it in a day or so
  3. VNC will not let me connect, similar issue to miniDLNA

With problems 2 and 3, i would use putty and able to connect it and reboot the machine. now that i try to reinstall dietpi, i get error and it will not proceed. exact same setup as before but USB HDD drive instead of USB pen drive and the parts as follow:

RPi B+
Insignia 2A power supply and wire
32Gb Samsung Ultra Plus microSD

I installed version 81 flawlessly before, but I tried the current build of Jessie and Wheezy and both will not install. I am on Windows 7 64bit and I used diskpart to clean and format my microSD card and imagewriter to write the new image to it.

I have attached a copy of the error I get.

I dont have spares to try but Iam not sure why its not installing with exact same parts and I tried with nothing plug in and same results.

Hi endlesszeal,

What you are reporting could be caused by the following:

  • Corrupt image write
  • Faulty SD card reader/writer
  • Faulty SD card
  • Faulty/unstable PSU
  • Overclocking
  • Hardware failure (i’am yet to see a RPi die, but you never know)

As the kernel error is so early in the boot sequence, I can only recommend you try the following:

thank you so much for the quick reply!!

I tried loading NOOBS on it and it turned on to be a corrupted/dying SD card. I was getting I/O errors and the data wouldnt transfer over to the memory card, so i tried switching cables and readers and same result. I tried all you’re suggestions except PSU and SD card, and no luck. As far as overclocking goes, i did have it set to 900mhz i think before i tried the fresh reinstall. Does that still stick? I was under the impression that as long as I dont adjust it via the config.txt or anything, the previous overclock should not sick with a new image.

now this leads to me a new question, what can i do to prevent corruption??? so frustrating that I just bought this card less than 3 months ago and its already corrupted. I never powered it off or anything and when i did shutdown, used the terminal to do the “sudo shutdown -h” or something of that nature to make sure I properly turned it off.

thanks again fourdee!

DietPi will set all RPi v1 to 900mhz during 1st run. Also known as the “safe” clock that the manufacture supports.

More often than not, SD card corruption is caused by a unstable/faulty PSU. I would recommend buying the official RPi PSU if you can. Generic/cheap PSU’s are hit and miss and generally its not worth the hassle.
I’ve had PSU’s fail on me, and i know how frustrating it can be.

Offical RPi PSU:

Sandisk cards are generally pretty stable and are what I use for DietPi testing. However, a faulty PSU could cause damage to the card during write. I would recommend using SD formatter and selecting size adjustment “On” and “Full (overwrite)”. This will write a 0 to each cell and should bring it back to life.

thank you very much! i just purchased a cheap samsung evo 16gb for $4 USD and just successfully installed Wheezy with the newest version.

as for the psu, i spent $20 USD on this one already and dont really wanna fork money over for another one just yet. if this microsd card corrupts again, i will get the official psu and upgrade to the newest RPi version instead of throwing money at my outdated model.

thanks again for the help!