[Fresh install] Cannot boot after shutting down/reboot

Creating a bug report/issue

I recently installed DietPi_RPi-ARMv8-Bullseye.iso onto an SSD to run on Raspberry PI 4. Upon first installation, everything works fine but after shutting down or restarting I run into an issue with MariaDB which outputs the below screenshots.

(MariaDB worked fine on the initial install with no configurations changed).

To be honest, most distros are struggling to stay stable or work for any prolonged period.

Apologies but I cannot boot to access any more information.

Any ideas?

To add, the keyboard is non-responsive during this message too so I cannot click ‘Enter’ to login ?

There seems to be issue with attached USB disk. Quite some I/O errors.

1 Like

Yeah…there is definitely something going on with the drive…when you start seeing inode entries…things are going bad

can you login after all the errors and run
You might have to unmount the drive if it attempts to mount it

umount -l /dev/sda1

e2fsck -p /dev/sda1

How to Use e2fsck to Check and Repair Disk Errors On ext File Systems | Linode

This should scan the drive and try to fix errors…

Thanks for your reply - I ended up switching back to an SD card and it works fine with a much faster boot than the external USB 3.0 SSD which is weird but works.

I will try to check & repair disk errors to see any effects too.

as you are using a RPi4, ensure your HDD/SSD has an own external PSU. Because USB ports of RPi4 are not designed to power such drives. You simply could have voltage issues on peak times leading to disk I/O errors.