Frequently losing network connectivity for less than a minute

Looking for some diagnosis ideas!

For several weeks (both on v8.1 and now 8.2.2) I have been having problems with my DietPi device disconnecting from my network at seemingly random intervals, generally every 10-30 minutes and just lasting 30-60 seconds. When I check the uptime in DietPi it says it has been on since my last intentional shutdown, and the Uptime number within apps like Sonarr says the same, so the device and services don’t seem to be crashing, just the network connection. It is noticeable because my Samba connection, SSH connection, and access to services (like Plex, Aria2, qbittorrent, etc) will become unavailable, then return in 30-60 seconds.

Before coming here to ask for DietPi help I thought to do the best I can to eliminate possible problems on the network, so I reconfigured some stuff to strip my network down to the bare minimum:

  • Only DietPi device and Ubiquiti AP connected to Modem/Router combo

  • Tried different Cat5e from Router to DietPi

  • Same behavior of inaccessible SSH, Samba, and services on two different computers and one phone

  • Internet and other network functionality remains normal while the DietPi device is inaccessible

  • Tried different power supply to DietPi device (12v 4A and 12v 5A)

Checking system logs (journalctl) I don’t see anything strange at the time of the disconnects, but I don’t know how to really read and understand them. I just switched from RAMlog to full logging and will take a look at that.

What should look at next?

Odroid HC2 (XU4), updated DietPi, userdata on an HDD

Do you use DHCP or Static IP? Are there any flaps on the interface? Any errors?
Is there any dietpi-service restart going on? Some backup?

you can have a look into dmesg if there is a sign about loosing interface/network connection.