Following a system update, system broken and I have not been able to restore it

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
  • Distro version | bullseye 0
  • Kernel version | Linux thebearspi 5.15.32-v8+ #1538 SMP PREEMPT Thu Mar 31 19:40:39 BST 2022 aarch64 GNU/Linux
  • SBC model | RPi 4 Model B (aarch64)
  • Power supply used | 5V Pi foundation power supply
  • SD card used | Sandisk Extreme 32GB (now upgraded to 64GB)

Additional Information (if applicable)

  • Software title | Nextcloud, MariaDB, mysql, redis-server
  • Was the software title installed freshly or updated/migrated? updated
  • Can this issue be replicated on a fresh installation of DietPi? I have no idea what has truely happened, so I cannot answer this.
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

Expected behaviour

I was previously running a Nextcloud instance, as well as pi.hole, docker, portainer, and RPI-monitor. Upon seeing updates were required I type in the command to find there were 40 updates required, so agree for them to be installed, assuming that following the updates running I would be able to continue using my cloud drive as before.

Actual behaviour

Following this update my system would not reboot and would hang constantly on redis-server checks. I found this to be my 32GB SD card, which only days before had been around 40% used, was now 100% used.
Since then I have tried to track down the cause of this increase in data (it is in the lost+found but I have no idea what it is), lost access to Nextcloud, and wasn’t able to restore it.
Finally I moved the system from the 32GB microSD to a 64GB microSD and was able to run a system update and start a re-install of Nextcloud.
During the re-install several errors came up in regard to mysql database having duplicate entries and the config.php missing information (its blank). Currently dietpi-software says Nextcloud is installed, but in CLI it states it is not.

Extra details

Feeling like an old man… can’t find the sodding edit button on here to change the title of this post (I’m assuming there is one).

I have found the same/ very similar issue on github that occurred 5 years ago but after reading through the conversation it is unclear (to me at least) what the resolution of the situation was.

The github post is: DietPi-Software | Nextcloud: install fails - only a limited number of commands #1314 (DietPi-Software | Nextcloud: install fails - only a limited number of commands · Issue #1314 · MichaIng/DietPi · GitHub)

ah that was you. Honestly I’m not sure what status your installation is. Can you share following as a starting point:

dietpi-services status

And to test some commands


Certainly, and thank you in advance.

dietpi-services status:
Mode: status

[ OK ] DietPi-Services | nmbd active (running) since Fri 2022-07-15 13:53:17 BST; 22h ago
[ OK ] DietPi-Services | smbd active (running) since Fri 2022-07-15 13:53:21 BST; 22h ago
[ OK ] DietPi-Services | redis-server active (running) since Fri 2022-07-15 13:53:21 BST; 22h ago
[ OK ] DietPi-Services | mariadb active (running) since Fri 2022-07-15 13:53:23 BST; 22h ago
[ OK ] DietPi-Services | php7.4-fpm active (running) since Fri 2022-07-15 13:53:24 BST; 22h ago
[ OK ] DietPi-Services | lighttpd active (running) since Fri 2022-07-15 13:53:25 BST; 22h ago
[ OK ] DietPi-Services | rpimonitor active (running) since Fri 2022-07-15 13:53:26 BST; 22h ago
[ OK ] DietPi-Services | docker active (running) since Fri 2022-07-15 13:53:26 BST; 22h ago
[ OK ] DietPi-Services | cron active (running) since Fri 2022-07-15 13:53:26 BST; 22h ago
[ OK ] DietPi-Services | ssh active (running) since Fri 2022-07-15 13:53:14 BST; 22h ago
[ OK ] DietPi-Services | zerotier-one active (running) since Fri 2022-07-15 13:53:13 BST; 22h ago
[ INFO ] DietPi-Services | dietpi-cloudshell inactive (dead)
[ OK ] DietPi-Services | dietpi-ramlog active (exited) since Fri 2022-07-15 13:53:12 BST; 22h ago
[ OK ] DietPi-Services | dietpi-preboot active (exited) since Fri 2022-07-15 13:53:13 BST; 22h ago
[ OK ] DietPi-Services | dietpi-postboot active (exited) since Fri 2022-07-15 13:53:13 BST; 22h ago
[ INFO ] DietPi-Services | dietpi-wifi-monitor inactive (dead)

#Nextcloud is not installed - only a limited number of commands are available
Nextcloud 23.0.3

command [options] [arguments]

-h, --help Display this help message
-q, --quiet Do not output any message
-V, --version Display this application version
–ansi Force ANSI output
–no-ansi Disable ANSI output
-n, --no-interaction Do not ask any interactive question
–no-warnings Skip global warnings, show command output only
-v|vv|vvv, --verbose Increase the verbosity of messages: 1 for normal output, 2 for more verbose output and 3 for debug

Available commands:
check check dependencies of the server environment
help Display help for a command
list List commands
status show some status information
app:check-code check code to be compliant
integrity:check-app Check integrity of an app using a signature.
integrity:check-core Check integrity of core code using a signature.
integrity:sign-app Signs an app using a private key.
integrity:sign-core Sign core using a private key.
l10n:createjs Create javascript translation files for a given app
maintenance:install install Nextcloud

(I don’t think I need to print all of the --help results but as I am not totally sure, as you can clearly see, I have!).

is that you who opened the very same issue on GitHub? Error re-installing Nextcloud Instance · Issue #5626 · MichaIng/DietPi · GitHub

Yes, BristolPiggy (awful name but will live with it for now).

I tried to re-install it all over again on a second day (and after a good rest/ time away from it) but this time when the errors were thrown, rather than getting flustered I copied over the error report.

I wasn’t sure if errors needed to be recorded under the official hub and on here, or just one, so I went with both just in case.

pls try to stick to a single platform. It doesn’t make sense to open the same issue twice.

Sure, I just figured that there were two places to put issues for a reason, if not, why have two places?

For future issues, and probably most importantly, which is the better site to discuss our experiences on? Here or Github (I’m assuming here as we are communicating here).

To move forward, should I close the issue one on Github? I don’t want to cause any more of a cuffuffle (something I manage to do unintentionally but way to often unfortunately).

Well we have 3 platform because not every user like GitHub and feels more comfortable on a forum.

Basically it doesn’t matter as we have same moderator on both platform. Usually our developer is more active on GitHub as this is our development platform.

let’s continue this topic on your GitHub issue