First boot issue

Creating a bug report/issue

Setting up raspberry pi headless and disconnected due to not having time, when i came back to connect again it gave me the error of “dietp first run setup is on another screen”

Required Information

  • DietPi version | 8
  • Distro version | bullseye
  • Kernel version | Linux DietPi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
  • Architecture | arm64
  • SBC model | Pi 3 B
  • Power supply used | 5.5v 2.4a
  • SD card used | Sandisk 8gb

Steps to reproduce

  1. Connect with ssh
  2. disconnect

Expected behaviour

  • session be saved?

Actual behaviour

  • not saving

Extra details

  • "dietpi is running first setup on another screen (pid=441)

What does it mean you disconnected? Did you closed the SSH session? You could try to reboot to get back the initial setup.

closed ssh session and tried rebooting, this appears still

Did you set the AUTO_SETUP_AUTOMATED=1 flag? If so it is expected. Wait for it to finish. You can monitor it via htop.

1 Like

Did you configured auto setup?

I ran autosetup the day before, and it appears to be finished

Hmm, obviously it did not finish. Can you check htop whether some dietpi-login process is running and probably some sub process?

You can kill the dietpi-login process via htop as well and restart the setup via exec bash on SSH.