Finished installing everything on Pi 1B, but can’t exit dietpi-software splash screen

Hi everyone,

I don’t know what’s going on, but I’ve spent the last few hours loading up various software on the Pi and finally troubleshooting the issue with my static ip, stupid hue bridge.

But I’m now stuck. I had this happen in a prior install and just ended up redoing it, but I can’t remember if that worked.

I have everything done and set like I need it, but nothing I do will exit the software install. I can install and uninstall software just fine, but every time it leads me back to the software GUI and will not go away.

I’m very close to tears and being bald. I can’t even SSH in to kill it, because of the error that an install is currently running.

Thanks in advance.

Okay so while waiting I tried again. Loaded from PINN so I have the ability to add more in later, I wiped and reinstalled dietpi

Outside of the NTP issue which I was able to resolve by cancelling the boot process, purging NTP and then specifying my NTP pool, I cannot ever EVER exit dietpi-software.

Ever. Even loaded on its own, if I hit exit the screen flashes and it brings me back to the install screen.

The issue is I’m running a few things on the Pi that require me being able to ssh into it in a headless manner. Problem is any time the Pi reboots, Power outages whatever, I am FORCED into and stuck in the dietpi-software menu.

I’m going to try and install it directly from the IMG file and see if that works, but I don’t know what’s going on. I don’t know how to solve the NTP/timesyncd issues if those come up again. This wasn’t an issue the first go around.


same problem here…no idea how to escape the Dietpi-Software Window.

Does nobody know a solution???


Actually, I do.

Download the dietpi image and install it directly. Use anything but Pi baker and you’ll be good.

Didn’t work with Pi Baker, but I used Etcher and it worked. Loaded everything perfectly into my Pi and it ran without issue, I tried the install 3-4 times before that and I got nowhere. Seems like what they include in PINN doesn’t work.

…I used Etcher (Mac). Tried also ApplePi_Baker and go the same result :frowning:


Hey guys,

note that our images are full SDcard images, so they are meant to overwrite everything, leaving (on RPi) only two partitions boot and root. I am not sure but think you cannot use them well with things like NOOBS or PINN.

Simply use Ether or Rufus to flash the image directly onto the SDcard and you are good.

Now about the DietPi-Software loop:

  • So on first boot DietPi-Update finishes, DietPi-Software prompts, you select desired software and Go >> Install, then reboot, and then again on login DietPi-Software starts?
  • This would mean that the desired install stage was not synced successfully to disk. Note that you can always SSH into it. You will see messages that you should finish first run setup on the other screen but you can exit to terminal by pressing ctrl+c which is also shown within the message.
  • When doing the above to exit to terminal for debug it would be great if you could paste the following:
cat /DietPi/dietpi/.install_stage
cat /var/tmp/dietpi/logs/dietpi-ramdisk.log
cat /var/tmp/dietpi/logs/dietpi-firstrun-setup.log

Hi MichaIng,

thanks, that did help. I could escape the loop via SSH. I saw that there was an update to DietPie 6.22 (was 6.18) and after the update, the loop did not show up again.

The Roon bridge setup did go through, but was not recognized by Roon…so I used the instructions on the Roon side to install it by hand. Now it all works! Thanks again :slight_smile:

Best regards


Hmm, strange that the update was not done automatically BEFORE dietpi-software prompt happened (?). Actually on first boot, DietPi-Update should run automatically and after finished (so v6.22 applied) DietPi-Software should prompt.

However good that it works now. I will check the Roon install.


I tried a few fresh installs, but it definitely did not do the update to 6.2x. BTW, my system is a Tinkerboard S, not a Pi, but I had the same loop than the OP.

I installed MC and ALSA…both I could find, but the Roon did not show up. Only after I did it manually with the version from the Roon website, I got it working.


We recognized some potential issues with older images and first run update. The issue is that a reboot is done BEFORE incremental patches update the system and enable e.g. new DietPi services and login scripts. On reboot these services/scripts are then missing/not loaded which can lead to the update is not rerunning to apply the still missing incremental patches… And since the install stage is not updated, you face the first run login prompt every time again.

Please try the the steps provided here to apply first run update/setup correctly this time. It will not touch any manully installed software and such, so can be done safely: