Faulty xu4 USB3 ports? [solved - use ext4 not ntfs]

I think my odroid xu4 USB3 ports are faulty. Here is what I have tried:

I’m trying to set up a NAS using my new odroid, and I am getting abysmal write speeds of 10MB/s. I have a USB3 external hard drive (WD Elements) connected on one of the usb 3 ports. I’ve narrowed the problem to being able to write to the external hard drive. If I plug the same hard drive into my windows machine, I get about 130MB/s read and write speeds (It is formatted as ntfs).

I’ve tried 3 different os images - omv (kernel 4.9), dietpi(kernel 3.10), and ubuntu(kernel 4.14) - and my drive writes never get above 10MB/s. I’ve tried all the tricks I can google like mounting the hard drive with big_writes, setting the processor affinity (already included in 4.14), ensuring the cpu settings are ‘ondemand’, etc, with no luck. I’ve included a screen shot below of the dietpi bench marks.

Anything else I might try to bump up the speeds? I’d like to keep my hard drives formatted as ntfs (I see all tutorials suggest ext4) and I’d be happy with even 30MB/s write speeds to beat my current setup.

Thank you!

Check this thread:



Thanks John.

I’ll have physical access to the device in a few hours and then I’ll try cleaning it.

Here is the current output I see, which looks to me like the xu4 is recognizing my external hard drives as usb3 (5000M). The read speed (78MB/s) seems to be above USB 2.0 limits (60MB/s).

I just cleaned the usb ports, and I see no difference in the benchmark.

Anything else I might try?

Would it be worth trying an ext4 format to see if speeds improve any, and if so then a hardware problem is less likely?

Or try USB flash ext4 formatted?

Try the Odroid forum?

Just tested my Cloudshell HD which is indirectly attached to a USB 3 port:

Write = 70.6 MB/s | Read = 98.8 MB/s

And USB 3 flash drive:

Write = 2.1 MB/s | Read = 34.6 MB/s


Looks like not using ext4 is the problem. I ran the benchmark and top at the same time - mount.ntfs was maxing out one of the cores. I bit the bullet and I partitioned one of my hard drives to ext4 - night and day difference.

I’m using rsync now and seeing 60MB/s going from reading ntfs to ext4. Just did a test over sshfs and i’m seeing about 55MB/s writing to ext4. I still want to see if I can get that higher, but I’m pretty happy with that speed.

Thank you John!