fastcgi-problem with dietpi x86 lighttpd nextcloud collabora [solved]

Hi,

I am running on dietpi x86 and installed LLMP and nextcloud. In nextcloud I activated the collabora CODE - Server.

Formerly I used Arch Linux and nextcloud worked with the LLMP-stack pretty well, even the collabora-server.

When I try to work with a document in collabora there is no connection to the collabora-server. The workspace remains empty.

The lighttpd error.log shows the following entry:

(mod_fastcgi.c.421) FastCGI-stderr: PHP message: PHP Warning:  file_get_contents(http://localhost:9982/hosting/capabilities): failed to open stream: HTTP request failed! in /var/www/nextcloud/apps/richdocumentscode/proxy.php on line 208

Has anyone an idea how to fix it?

Thank you in advance

Rick

Hi,

many thanks for your message. According the error, your system is trying to connect to http://localhost:9982/hosting/capabilities

can you check LISTEN ports

ss -tulpn | grep LISTEN

Thank you for the fast response.

I can call the page

http://localhost:9982/hosting/capabilities

it shows a lot of information.

ss -tulpn | grep LISTEN

shows a lot of ports, so I used

ss -tulpn | grep LISTEN | grep 9982

and I got:

tcp    LISTEN   0        64                      *:9982                 *:*      users:(("loolwsd",pid=10547,fd=18))

So I think, the adress is reachable, I have no clue, why fastcgi says “fails to open the Stream”

ok it took me a while to get a x86 system up and running but finally it’s working for me. Can you check following on nextcloud

Go to

  1. Settings
  2. Administration
  3. Collabora Online Development Edition
  4. check “Use your own server”
  5. enter “http://<your_ip>:9982”

should looks like this


now I’m able to open documents

Hi,

I had to sleep and work a liitle bit in meantime.

I am using the nextcloud collabora CODE-Server-App.

I tried to activate the first menu point “own server” with the following adress (btw.: the IP is the correct one of the localhost): http://192.168.178.80:9982

The server was accepted with a green checkmark, but when i tried to edit an document, the screen remained black. That a little less than before, when the screen went grey and showed the menu-headline.

I mentioned that the “own server” is only accepted, when i startet the built-in CODE-server before.

Thank you for your help!

I just found the origin of the problem and the solution:

In the lighty config-file

/etc/lighttpd/lighttpd.conf

in the section

server.http-parseopts = (
  "header-strict"           => "enable",# default
  "host-strict"             => "enable",# default
  "host-normalize"          => "enable",# default
  "url-normalize-unreserved"=> "enable",# recommended highly
  "url-normalize-required"  => "disable",# recommended
  "url-ctrls-reject"        => "enable",# recommended
  "url-path-2f-decode"      => "enable",# recommended highly (unless breaks app)
 #"url-path-2f-reject"      => "enable",
  "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
 #"url-path-dotseg-reject"  => "enable",
 #"url-query-20-plus"       => "enable",# consistency in query string
)

the following keyword

"url-normalize-required"  => "disable",# recommended

must to be disabled.

Maybe that information maybe helpful for anybody :wink:

strange for me this is working with default web server settings

I have tried this, but it does not work for me, I have been testing for several days … there is a docker with collabora-code, I have it working, in the Nextcloud configuration it makes a green check, but when opening the file, the screen remains blank.

There is no easy way to configure collaborate with dietpi? collabora / onlyoffice / ms Office online

Thanks

This not work on Arm64? it would be great for raspberry, because I think there is no other alternative.

for me it is working well on RPi4B 64bit

The fix (config change) should not required anymore as the underlying bug has been solved in the Debian package. At least when it’s the same underlying issue that caused logout to fail with Lighttpd and that was fixed with the same config change :thinking:.

On my test it is working OOTB, without any fix :slight_smile:

and your Colabora is installed on a docker? or how do you have it installed?
I will try again, I would like to leave it working, although it consumes a lot of Ram, it is very useful.
Thank you!

on my test I simply activated it inside NextCloud without any docker instance.

I just installed again collaborates from the application manager.

the problem is this, when opening a document it appears like this … nothing else, no error messages to correct the problem.
I don’t know why it doesn’t work for me.


There might be one main difference. On my test, I explicitly set my own Collabora Online-server and did not use the built-in one.


This way I’m able to open documents




What is your current configuration?
finally I decided on a local installation, to exclude possible docker problems, but with the same result … I don’t know what else to try, I would like to have an office package on the raspberry but I am not able
There is no crash log in nextcloud
CCCC.png

Let me copy myself as already written above

On my test, I explicitly set > my own Collabora Online-server > and did not use the > built-in one> .

Seen your 2nd screen print