Fails to connect to repository. 111: connection refused


  • Date | Sat Sep 17 13:02:21 BST 2022
  • DietPi version | v7.9.3 (MichaIng/master)
  • Image creator | DietPi Core Team
  • Pre-image | Armbian
  • Hardware | Odroid C1 (armv7l) (ID=10)
  • Kernel version | Linux DietPi 5.10.21-meson #21.02.3 SMP Mon Mar 8 07:39:35 UTC 2021 armv7l GNU/Linux
  • Distro | bullseye (ID=6)
  • Command | apt-get -q update
  • Exit code | 255
  • Software title | DietPi-Update

Additional logs:

Hit:1 bullseye-security InRelease
Hit:2 bullseye InRelease
Hit:3 bullseye-updates InRelease
Hit:4 bullseye-backports InRelease
Err:5 bullseye InRelease
  Could not connect to ( - connect (111: Connection refused)
Reading package lists...
W: Failed to fetch  Could not connect to ( - connect (111: Connection refused)
W: Some index files failed to download. They have been ignored, or old ones used instead.

so it’s a new install on an Odroid C1… it was originally an upgrade on a C1 from 8.2 to 8.8.1 but it can’t connect to the, even though I can ping it and go there in a browser.

Pinging with 32 bytes of data:
Reply from bytes=32 time=36ms TTL=51
Reply from bytes=32 time=34ms TTL=51
Reply from bytes=32 time=31ms TTL=51
Reply from bytes=32 time=34ms TTL=51

I am doing a clean install using an older version of the C1 download which will boot, whereas the current one will never boot. the blue light stays on and it just hangs.

I’d like to get my 2 C1 boards in use again, they were running OctoPrint before I tried to update them now they don’t run anything.

any help would be appreciated.

See: [FAILED] DietPi-Update | Unable to continue, DietPi-Update will now terminate. on Odroid C2 - #4 by suj

tried what you said, I must still be doing something wrong or missing a step. now at best I get 2 other IPs to not work… accidentally posted the reply to the other thread.

I have no idea why it’s not working, guess I’ll wait until the next release of DietPi that includes these fixes natively.

thanks… I did what you outlined and now it doesn’t find two other addresses

 APT update                                                                                                           │
 | - Command: apt-get -q update                                                                                        │
│  - Exit code: 100                                                                                                    │
│  - DietPi version: v7.9.3 (MichaIng/master) | HW_MODEL: 10 | HW_ARCH: 2 | DISTRO: 6                                  │
│  - Image creator: DietPi Core Team                                                                                   │
│  - Pre-image: Armbian                                                                                                │
│  - Error log:                                                                                                        │

│ Err:5 bullseye-backports Release                                                  │
│   404  Not Found [IP: 443]                                                                            │
│ Err:6 bullseye-updates Release                                                  │
│   404  Not Found [IP: 443]

well, the repository you added now is not supporting bullseye-backports and bullseye-updates. Maybe the config is not correct. Let’s check the current source file config

for i in /etc/apt/sources.list{,.d/*.list}; do echo "$i:"; cat "$i"; done

well I had been up all night, so I crashed shortly after my last post.
I came at it fresh, changed the apt source in dietpi-config and when I reran it it worked.
Guess I need a little bit better understanding or a more step by step set of instructions

usually there is no need to change any apt source list as they should work ootb. It would need to be reported upstream if there is an error with a specific mirror.