Failed to start systemd-timesyncd.service after crash

Hello,
I have random crashes and do not know where they come from.
Now I wanted to enable Full Log, but when I try to enable/install it, I get the error that systemd-timesyncd.service cannot be started.

Does anyone know how I can fix this?

ERROR:
Failed to start systemd-timesyncd.service: Unit systemd-timesyncd.service is masked.

Usually this is the time sync service and should not be masked. You would need to unmask the service first

systemctl unmask systemd-timesyncd.service
systemctl enable systemd-timesyncd.service
systemctl start systemd-timesyncd.service

Sadly it’s not working.

root@DietPi:~# systemctl unmask systemd-timesyncd.service
Removed /etc/systemd/system/systemd-timesyncd.service.
root@DietPi:~# systemctl enable systemd-timesyncd.service
Failed to enable unit: Unit file systemd-timesyncd.service does not exist.

timesyncd is part of systemd package, if I’m not mistaken. And I’m not sure how it could be possible the service missing. You could give it a try to reinstall systemd

apt install --reinstall systemd

This helps.
Thank you.

However, I still have the problem with the random crashes. I think this is due to the USB from my Odroid N2+. Everything is running and all of a sudden the entire device reboots.

I have read that there were these problems before, were they fixed in the meantime?

Should I open a new thread for this?

I have read that there were these problems before, were they fixed in the meantime?

what problems you mean?

I have an external hard drive mounted.
If there are no accesses to the hard disk, the system runs for several days without problems (I have not tested it for more than a few days).
But when I have regular iops the system crashes after 1 hour at the latest.

This also created the problem with Systemd (I didn’t change anything myself and didn’t add any services).
I also looked at the graphs in the Dietpi dashboard and everything was normal there.
Max 1.3GB RAM usage
Max 50% CPU usage
And the emmc module memory was also at 2GB out of 32GB.
This happens even without the dashboard installed.

no I mean you pointed to some problems you read about. Maybe you can link them

Just Google it… The odroid forum is under maintenance.
Also here https://github.com/MichaIng/DietPi/issues/4188

Some people are saying it’s fixed… But I have problems with it.

at least from our side the issue is not closed indicating no fix from our side. Not sure if we can do anything from DietPi side if it is kernel related.

With Bullseye systemd-timesyncd has become an own package, probably it got autoremoved during Buster => Bullseye upgrade? Not sure when I added a step to prevent it to our upgrade blog.

apt install systemd-timesyncd

I think the Odroid Kernel is too old.
DietPi is using V4.9 and Armbian 5.10

it depends on the image used. Older DietPi images are build on different source images not offering newer kernel. At least some of the new Bullseye images have been recreated based on Armbian image. As well you are able to create an Armbian system first and run our PREP script to install DietPi on top.

This is very interesting, because with armbian everything runs without problems. I would then try this out. Can you send the link to the current script?

there you go https://dietpi.com/docs/hardware/#make-your-own-distribution

The complete OS now broke. I tried it multiple times…
After the reboot the heartbeat LED is after the reboot ON and not blinking.

you mean, if you try to convert the Armbian image?

Yes, I tried it with my OS in use but also with a fresh installation.
The convert script runs without problems, but after reboot the heartbeat LED is permanently on. I also noticed that the external USB hard drive only starts in USB 2.0 mode.

what image you used as base before running PREP?

https://www.armbian.com/odroid-n2/#kernels-archive-all
I used the Buster with the 5.10.y kernel.