Failed plex media server upgrade / Dietpi-update 3 usage option (update dietpi without apt get upgrade)

Can an additional usage option be added to dietpi-update. Option 3? To perform a dietpi-update without running sudo apt upgrade.

Why? This is inspired by a problem that I have. After running dietpi-update (which also runs sudo apt upgrade) the plexmediaserver package is also upgraded. As a result, plex no longer works. This has been occurring for six months.

Option 3 usage would at least allow me to upgrade dietpi scripts (and non plex packages specifically). There are probably other benefits to a narrow dietpi-update restricted to just the dietpi software scripts.

I don’t think that will happen. We trigger apt update on purpose. What you could do is pin the plexmediaserver package to prevent updates of this package.

But perhaps @MichaIng disagrees.

Thank you. I have used:
sudo apt-mark hold plexmediaserver
to prevent the package from upgrading. Dietpi-update has upgraded dietpi to the latest version and plex continues to function.

Hopefully, a future upgrade of plexmediaserver in the future wont break the package. I’ll test monthly.

I run dietpi on proxmox and I can revert to a prior snapshot if a plexmediaserver upgrade fails. I can live without the current version of plexmediaserver.

Did you already reported your issue with Plex to the Plex developer?

I also can’t find any other plex user, or dietpi user, that has reported this problem. I am not confident that this is a problem beyond my installation. I haven’t reported to plex developer.

I am just running vanilla dietpi (no customisations outside dietpi menus). I am not sure I could provide a quality description of what the problem is or quality supporting information.

We just install Plex from the official repository. I’m not sure if we can do anything with it. At least from my side, I can’t test it because I don’t use Plex and don’t have a Plex account. Maybe @MichaIng has one.

In the interest of keeping this thread as fully informed as possible for others that may find it with the same problem.

After a successful dietpi-update (with plexmediaserver labeled as hold), I ran the “distro upgrade to bookworm script” with plex package re-marked, re-confirmed as hold. Post bookworm upgrade, plex did not work.

I am guessing that the “distro upgrade to bookworm script” ignores the “hold” label and upgrade the plex package.

As a start, you could check the logs of the Plex server:

journalctl -u plexmediaserver