'fail to fetch' and DNS related issues?

I’m at my wit’s end here. First, everything has been working great for at least weeks, then suddenly I was having trouble connecting to my HC2(XU4) with Samba and it was persistent through updates and restarts of client, router, and server. So I thought I would try reinstalling Samba in DietPi. I removed Samba through dietpi-software.

Then, I went to reinstall Samba, and the confusion began. First thing I noticed is that it hangs for 10 seconds or more at the ‘Checking DNS resolver’ step, but does proceed:
resolver.png
Typically the first time into dietpi-software I can get into the menu, but when I proceed to install Samba (or ProFTP, tried that too), I end up with a “failed to fetch” error like the following two:


Or:

If, before a reboot, I proceed with Retry or Exit and try dietpi-software again, I typically (always?) get this DNS error:


I searched the ping command in that DNS error and found someone else having problems resolving one.one.one.one (here) and I followed a recommendation to turn of IPv6. I can successfully run the “ping -c 1 one.one.one.one” and “ping -4 -c 1 one.one.one.one” commands mentioned there, but if I run the “ping -c 1 -W 5 one.one.one.one” command in the error above it fails, 100% packet loss. I have tried changing DNS in the dietpi.txt file to 8.8.8.8 and google.com, but the results were the same.

Please help! I can’t make any progress on installing Samba (or ProFTP) and I’m quite confused why it’s failing. Sorry this is long, just trying to be thorough.

looks like network issues to connect to specific apt sources. That could be local or even the requested source did not exist anymore on the target server.

First question: do you have a spare SD card and would it be possible to test one of the new Buster images that are offered?

https://dietpi.com/downloads/images/DietPi_OdroidXU4-ARMv7-Buster.7z

Thank you for the reply. I’m really hoping to avoid a fresh install since I’ve had to do that a couple times before and it seems like it takes me half a day to get everything back how I like it. If a Buster image works well does it tell us anything to fix my current install, or should I just be preparing for a full change-over? Any ideas on exploring the possibility of a local problem? I haven’t changed anything recently and there’s nothing particularly unusual about my network.

well it was just an idea if you would have a spare SD card to test the Buster image as you are still on Strech which is basically the old Debian 9 version.

Ok let’s try to find our whats going on on your system. pls can you run a ping on command line. Let’s keep it running for around 1-2 minutes to see if there are issues on connectivity. Pls post how many package you are going to loose.

ping 8.8.8.8

next to that, pls can you run the following and past the result. Don’t do a screenshot. Just copy the result from your SSH window.

apt update

thank you for the continued help!

--- 8.8.8.8 ping statistics ---
355 packets transmitted, 354 received, 0% packet loss, time 354291ms
rtt min/avg/max/mdev = 39.545/77.288/1343.479/106.787 ms, pipe 2



apt update
Err:1 https://download.mono-project.com/repo/debian stretch InRelease
  Failed to connect to download.mono-project.com port 443: Network is unreachable
Hit:2 http://fuzon.co.uk/meveric all InRelease              
Hit:3 https://deb.nodesource.com/node_12.x stretch InRelease                     
Hit:4 http://fuzon.co.uk/meveric stretch InRelease                               
Ign:5 https://downloads.plex.tv/repo/deb public InRelease                        
Hit:6 https://downloads.plex.tv/repo/deb public Release    
Get:8 https://packages.sury.org/php stretch InRelease [6,760 B]
Ign:9 https://deb.debian.org/debian stretch InRelease                                                                  
Get:11 https://deb.debian.org/debian stretch-updates InRelease [91.0 kB]                                               
Err:10 https://oph.mdrjr.net/meveric all InRelease                                                                     
  Failed to connect to oph.mdrjr.net port 443: Network is unreachable
Get:12 https://packages.sury.org/php stretch/main armhf Packages [133 kB]                                              
Hit:13 https://apt.sonarr.tv develop InRelease                                                                         
Get:14 https://deb.debian.org/debian-security stretch/updates InRelease [94.3 kB]                                      
Get:15 https://deb.debian.org/debian stretch-backports InRelease [91.8 kB]                                             
Hit:16 https://deb.debian.org/debian stretch Release                                                                   
Get:17 https://deb.debian.org/debian stretch-backports/main armhf Packages.diff/Index [27.8 kB]                        
Get:19 https://deb.debian.org/debian-security stretch/updates/main armhf Packages [498 kB]                             
Get:20 https://deb.debian.org/debian stretch-backports/main armhf Packages 2020-03-26-1417.37.pdiff [1,125 B]          
Get:21 https://deb.debian.org/debian stretch-backports/main armhf Packages 2020-03-26-2019.25.pdiff [1,574 B]          
Get:21 https://deb.debian.org/debian stretch-backports/main armhf Packages 2020-03-26-2019.25.pdiff [1,574 B]          
Fetched 945 kB in 4min 13s (3,723 B/s)                                                                                 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
11 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://oph.mdrjr.net/meveric/dists/all/InRelease  Failed to connect to oph.mdrjr.net port 443: Network is unreachable
W: Failed to fetch https://download.mono-project.com/repo/debian/dists/stretch/InRelease  Failed to connect to download.mono-project.com port 443: Network is unreachable
W: Some index files failed to download. They have been ignored, or old ones used instead.

I’m still hoping to keep my old install as I’ve had bad experience in the past with using backup and restore.

However, I did download the Buster image to a blank SD and gave it a shot. Booted up normal, I chose a few softwares to install, and got this:

 ┌──────────────────────────┤ DietPi-Software | Error handler ├───────────────────────────┐
                       │  - Command: G_AGDUG                                                                      
                       │  - Exit code: 100                                                                        
                       │  - DietPi version: v6.28.0 (MichaIng/master) | HW_MODEL:11 | HW_ARCH:2 | DISTRO:5        
                       │  - Image creator: DietPi Core Team                                                       
                       │  - Pre-image: Meveric                                                                    
                       │                                                                                          
                       │ Log file content:                                                                        
                       │ E: Failed to fetch                                                                       
                       │ http://fuzon.co.uk/meveric/pool/xu3/l/linux-4.14.173+/linux-image-4.14.173+_4.14.173-2   
                       │ 0200317-xu4_armhf.deb  Could not connect to fuzon.co.uk:80 (185.101.93.34). - connect    
                       │ (101: Network is unreachable)                                                            
                       │ E: Failed to fetch                                                                       
                       │ http://fuzon.co.uk/meveric/pool/xu3/l/linux-image-4.14-armhf-odroid-xu4/linux-image-4.   
                       │ 14-armhf-odroid-xu4_4.14.173-1_armhf.deb  Unable to connect to fuzon.co.uk:http:         
                       │                                                                                          
                       │           Retry         : Re-run the last command that failed                            
                       │           DietPi-Config : Edit network, APT/NTP mirror settings etc                      
                       │           Send report   : Uploads bugreport containing system info to DietPi             
                       │                                                                                          
                       │                                                                                          
                       │                        <Ok>                            <Exit>                            
                       │                                                                                        │ 
                       └────────────────────────────────────────────────────────────────────────────────────────┘

Could it be that someone is blocking your access to the internet?
Are you connecting from home or office?
Maybe due to state censorship?

I am afraid that dietpi lacks traceroute and my feeling is that you haven’t installed it or mtr.
Resolving hostnames work properly. It’s something else that is rejecting your traffic.

at least I would try to open the following on a web browser on same network

https://dietpi.com/meveric/pool/xu3/l/linux-image-4.14-armhf-odroid-xu4/linux-image-4.14-armhf-odroid-xu4_4.14.180-1_armhf.deb

At least I don’t have issues with it. I can open and download the file from my side. So the Website is working and accessible from internet

same for the other 2 links

https://download.mono-project.com/repo/debian/dists/buster/
https://oph.mdrjr.net/meveric/dists/all/

Do you use any own DNS server like PiHole or something like this?

trendy
you simply could install traceroute if you are missing it

apt install inetutils-traceroute

I know I can, I am not sure the OP can though.

well just give it a shot

This is home internet, coming from a WISP. I doubt it’s ISP or state censorship, and I can’t fathom the motive.

I did have PiHole as part of this DietPi install, but I have deactivated it, and the Buster image didn’t have it installed at all.

I am able to open all 3 of those links and download files on my computer on the same network. :thinking:

traceroute installed fine, here’s some I tried. what does !N mean? I’ll start googling…

root@DietPi:~# traceroute google.com
traceroute to google.com (216.239.38.120), 64 hops max
  1   192.168.1.1  2.449ms  2.832ms  4.121ms 
  2   192.168.14.1  11.712ms  7.949ms  16.074ms 
  3   192.168.13.1  16.001ms  9.857ms !N  8.056ms 
root@DietPi:~# traceroute fuzon.co.uk
traceroute to fuzon.co.uk (185.101.93.34), 64 hops max
  1   192.168.1.1  3.560ms  3.626ms  2.587ms 
  2   192.168.14.1  10.421ms  11.889ms  7.822ms 
  3   192.168.13.1  8.652ms !N  16.452ms  8.777ms 
root@DietPi:~# traceroute download.mono-project.com
traceroute to cs9.wpc.v0cdn.net (117.18.232.200), 64 hops max
  1   192.168.1.1  5.161ms  2.415ms  2.285ms 
  2   192.168.14.1  22.075ms  15.654ms  10.913ms 
  3   192.168.13.1  23.023ms !N  28.733ms  23.428ms 
root@DietPi:~# traceroute oph.mdrjr.net
traceroute to main.mdrjr.net (216.155.157.42), 64 hops max
  1   192.168.1.1  4.722ms  5.006ms  2.962ms 
  2   192.168.14.1  31.304ms  13.165ms  16.203ms 
  3   192.168.13.1  21.770ms !N  19.344ms  23.497ms

Hi,

honestly your trace looks quite strange. Doesn’t matter what you to trace, you have 3 hops only. And all 3 a from a privat network.

https://en.wikipedia.org/wiki/Private_network

And it looks like you never going to reach the target. Do you know what 192.168.14.1 and 192.168.13.1 is about? I assume 192.168.1.1 is your internet router.

For me the trace looks like this

traceroute to google.com (172.217.22.78), 64 hops max
  1   192.168.0.1  0.997ms  1.377ms  0.622ms
  2   192.168.2.1  2.029ms  1.408ms  1.477ms
  3   *  *  *
  4   *  *  *
  5   80.154.91.157  13.306ms  12.221ms  10.923ms
  6   217.0.197.229  17.690ms  15.671ms  16.970ms
  7   62.157.250.46  17.862ms  16.943ms  16.634ms
  8   *  *  *
  9   66.249.94.146  19.761ms  18.627ms  18.906ms
 10   108.170.251.209  17.685ms  17.335ms  16.382ms
 11   209.85.240.113  17.269ms  16.764ms  16.291ms
 12   172.217.22.78  17.289ms  15.951ms  15.797ms
root@DietPiVM1:~# traceroute fuzon.co.uk
traceroute to fuzon.co.uk (185.101.93.34), 64 hops max
  1   192.168.0.1  0.995ms  0.470ms  0.430ms
  2   192.168.2.1  1.834ms  1.509ms  1.116ms
  3   *  *  *
  4   *  *  *
  5   195.145.92.33  13.447ms  11.989ms  12.704ms
  6   217.5.116.42  17.404ms  17.078ms  17.300ms
  7   62.157.249.186  17.677ms  17.174ms  17.885ms
  8   129.250.6.13  25.879ms  *  *
  9   129.250.4.77  18.075ms  18.029ms  16.390ms
 10   213.198.72.154  17.311ms  17.008ms  17.001ms
 11   93.115.91.22  17.647ms  16.846ms  17.887ms
 12   5.254.68.150  18.226ms  16.858ms  16.233ms
 13   5.254.14.94  20.057ms  19.495ms  20.138ms
 14   62.141.47.20  20.522ms  20.393ms  19.923ms
 15   *  62.141.47.65  22.219ms  *
 16   *  *  *
 17   62.141.47.191  22.717ms  20.487ms  20.864ms
 18   194.125.248.134  21.252ms  20.247ms  19.790ms
 19   *  *  *
 20   185.101.93.34  23.051ms  20.278ms  21.864ms
root@DietPiVM1:~#

!N means that your machine received ICMP message “destination host unreachable”. Could be as well !P or !H

It is not so strange, you had seen this message before when you were trying to apt-get the packages.
Talk to your ISP, they have messed up something and they are rejecting these IP addresses for no apparent reason.

honestly I would go to find out what 192.168.14.1 and 192.168.13.1 is. These are 2 privat IP’s and trace stopped somewhere there.

It’s common for ISPs, especially WISPs to use private IPs in their backbone. That is not a problem.

well but he never reached the target on his trace

And that is why I advised him to contact his ISP.
If he was reaching the destination we wouldn’t be discussing the issue here.

But still the question why he is able to access the website from another computer on the same network while the SBC is failing?