External Wifi Card (NETIS WF2190) not detected

during startup of 102 my external wifi card was not detected. On 101 wifi card was detected.
I checked my input on the txt file so far.

Regards steven

Hi Steven,

What device are you running DietPi on (eg: Odroid)?

Also, please paste the results of the following:


Hey sorry i didnt answered that long.

I reinstalled dietpi on my sd card and wanted to start odroid xu4.

Additional i have the cloud.

I have the wireless network adapter: Netis WF2190 / Ac1200 wireless network adapter.

It is the fastest adapter wlan to usb on the market i seen since i need wlan and cannot connect via ethernet.

Additional i have a usb 3.0 hub which i plugged to the usb 3 port.

I did 3 tests: 1) Netis adapter plugged to the usb 2.0 port
2) Netis adapter plugged to the usb 3 hub
3) Netis adapter plugged directloi to the usb 3 port

In every of the 3 tests the adapter did not work.

But when im in the command screen and i plug of the netis adapter the following message appears:

618.587484 [c0] usb 3-1.2.3: USB disconnect, device number 10

I think odroid recognises adapter but not working properly since the lights on the adapter doesnt go on.

I attached the output of lssusb and lsmod as jpg format.

Plz help me since i dont know what i should do to get things work ;-(

Best regards and a nice new year!

Hi Soletto,

Looks like your device is:
0bda:8812 = 8812au

Have you tried probing the device?

modprobe 8812au

Its possible the kernel wasn’t built with support for your chipset, so it will need to be rebuilt.
I have contacted Meveric on the Odroid forums (DietPi uses his Jessie image as the base), hopefully he can give us some advice.

I spoke to Meveric and it turns out he has already added support for 8812au:

root@gamestation-turbo:~# modprobe 8812au
root@gamestation-turbo:~# lsmod
Module                  Size  Used by
8812au               1025785  0
zram                    9172  8
cfg80211              454265  0
rfkill                 12936  1 cfg80211
smsc95xx               17764  0
usbnet                 22193  1 smsc95xx
cp210x                  8641  0
ina231_sensor           8388  0
spi_s3c64xx            13713  0
snd_seq_midi            4857  0
snd_seq_midi_event      6152  1 snd_seq_midi
snd_seq                52878  2 snd_seq_midi_event,snd_seq_midi
snd_rawmidi            20142  1 snd_seq_midi
snd_seq_device          6169  3 snd_seq,snd_rawmidi,snd_seq_midi
fuse                   75445  3
root@gamestation-turbo:~# modinfo 8812au
filename:       /lib/modules/3.10.92+/kernel/backports/drivers/realtek/rtl8812au/8812au.ko
version:        v4.2.5_10143.20140103_ASUS
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
version:        backported from Linux (next-20150222-0-g53e418f1) using backports backports-20150222-0-g2745ccd
srcversion:     224BA195CD9D8D2FA9236C5
alias:          usb:v2357p0101d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3316d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3315d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07B8p8812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB30d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1740p0100d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1058p0632d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3313d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0586p3426d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E66p0022d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17D2d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0409p0408d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0789p016Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04BBp0952d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0DF6p0074d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA822d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p330Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v050Dp1106d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp8812d*dc*dsc*dp*ic*isc*ip*in*
intree:         Y
vermagic:       3.10.92+ SMP preempt mod_unload ARMv7 p2v8
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_regulatory_id:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_vht_enable:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)

You will need to run apt-get update and upgrade to install the latest kernel (3.10.92+):

apt-get update
apt-get upgrade

Best regards !!!

You are the best :smiley:

Hey i did setup new dietpi.

I connected both ethernet and netis wlan card.
It worked for the ethernet (i have wnce 2001)

After update and upgrade my netis worked. Light turned on. In the dietpi internet configurations there was standing: wlan connected / enable

But the internet test did not worked.

Very strange i cannot understand.

Maybe it is not possible to connect after the dietpi installation.

Would be great if you can implement the netis into the dietpi iso installation image so that it is working direct after installing the image.

Dont now how to do :frowning:

Since the Netis adapter worked in a previous version (I think 99 /100)

Regards Stefan

Hi Stefan,

It could be a network configuration issue. I will need some additional information on your system from you so I can look into this.

Please run the following and paste results:


Also, please upload the contents of these files: