External HDD problem since V159

Hello everyone!

Since Dietpi version 159 I notice that our external HDD starts differently. I created a custom startup script (this custom script works) with this command:

mount /dev/sda1 /mnt/data -o umask=000

That always worked well! But since DietPi version 159:

/dev/sda1 932G 350G 582G 38% /mnt/4E1AEA7B1AEA6007

For version 159:

/dev/sda1 932G 350G 582G 38% /mnt/data

ls -l /mnt

drwxrwxrwx 1 root root 8192 Aug 1 2015 4E1AEA7B1AEA6007
drwxr-xr-x 2 root root 4096 Oct 17 12:00 data
drwxrwxr-x 6 dietpi dietpi 4096 Jun 10 2017 dietpi_userdata
drwxr-xr-x 2 root root 4096 Mar 10 2017 ftp_client
drwxr-xr-x 2 root root 4096 Mar 10 2017 nfs_client
drwxr-xr-x 2 root root 4096 Mar 10 2017 samba

I didn’t create the 4E1AEA7B1AEA6007 folder. He did that self.

Does anyone know how this is coming? Of course I can solve it manually. But after every reboot I have to do that :imp:


please have a look:

DietPi-Drive Manager


Thank you! I see:

Weird! he is suddenly in the fstab:

UUID=4E1AEA7B1AEA6007 /mnt/4E1AEA7B1AEA6007 auto defaults,noatime,nofail,x-systemd.automount 0 0

I turned it off and now it works again.

No need for “custom startup script”, let’s dietpi-drive_manager do this.

If you need a special folder as mountpoint, create a symbolic link to /mnt/4E1AEA…

Thanks for the information and help! Has this changed in the latest Dietpi version? Since it was not a problem for this version?

I have now made a symlink and it works :smiley:

DietPi-Drive Manager is a feature since DietPi v131 (20 September 2016)

you can read Changelogs here and here