External HDD Issues

Hi all,

I recently got myself an external USB 3.0 SATA case for an old 2.5" SSHD of mine. I wish to use it as remote storage on my Raspberry Pi 4B, although I keep running into the same issue repeatedly. The drive itself is FAT32 formatted, I’ve checked its health on dietpi and Windows. Both Operating Systems report an OK status. However, the SSHD refuses to show up in /dev or a quick lsblk. If I plug it into Windows it shows up perfectly fine. I tried using a powered USB hub and it showed up, but not for long, either.

Here is the output of dmesg | grep sd[a-z], hoping someone can point me in the right direction.

If anyone needs more details, please ask :slight_smile:

Did you tried using DietPi Drive Manager to have you device mounted? In general it might be good to use an external power supply anyway.

I haven’t explicitly tried that. I was using the mount command. I’ll get back to you in a few with a status update.

Sorry to double-post, but I just tried using dietpi-drive_manager. This time, however, I used a regular USB stick (3.0 / 32GB). Didn’t take long before Windows couldn’t access the device anymore.

output from dmesg | grep sd[a-z].

Don’t get it, you have plugged the USB device into you DietPi? How does Windows fits into the picture? Do you use as well samba to populate and export the device to a windows based system?

Yes, the USB is plugged into the Raspberry Pi. Windows is being used to access a Samba share on the Pi.

Ok imported information. Let’s separate the topic. What is the status of you USB device on your DietPi system? Is the drive still accessible? Still visible using df command?

Here’s what I can see (see the photo for clarification, if needed):

  • I can see the device via the df command.
  • I don’t see it listed as /dev/sda in the /dev directory.
  • lsblk does not show anything referring to it.

Can you try a different usb port on your device?

Moving it to a different port after using device manager to unmount, it does not show up. I even refreshed the list.

Can you check /etc/fstab if the usb device is still in? If yes pls remove and reboot your system.

It’s not in /etc/fstab, so I just went and rebooted the Pi

And placing the stick in one of the other usb ports doesn’t show it up on drive manager? Did you checked the journal?

Right, I unmounted it before the reboot and then scanned for added or removed drives. Nothing came up. Now the Pi has rebooted and it sees the USB drive now.

EDIT: and it just disappeared.

Here’s some output I captured: https://pastebin.com/ZiUy0EM8

Anything in the journal about this?

Scanned the journal, pretty much the same output as my last post’s edit.


Hmm looks the usb device is simply disappearing. Well you could check with a different usb device to verify the behaviour, if possible.

On the other hand, do you have a different SD card? Maybe to verify with a standard raspbian lite.

I do have another micro SD card. I’ll try to raspbian lite. This is the second USB device I’ve tried with this, so it’s weird. I’ll report back on how raspbian lite is.

Ok using raspbian lite will verify if there is all fine one hardware. If raspbian lite is working, we can simply migrate to DietPi executing 1 script :wink:. Afterward we can check behaviour again. Hope we can get closer to it.

Alright, I am confused as to what happened here.

I had plugged in the micro HDMI and my keyboard and maybe after almost a minute, both of them stopped working.
I tried to change input back to HDMI and it refuses. Keyboard stopped working in the middle of trying to run lsblk to check for the USB.