External HDD in Odroid Cloudshell

Namaste from India.

First let me thank you all guys for this wonderful dietpi. you people are god sent :slight_smile:

I am just learning linux and embedded systems.

My Environment:
Odroid XU4 with cloudshell
diet pi version 101.

Things working fine.

  1. cloudshell
  2. owncloud

Things having trouble:

  1. have connected a hdd to the cloudshell it is not showing up.
  2. error in dmesg is showing this error message
    [ 4.542283] [c7] sda: sda1 sda2
    [ 8.937946] [c5] EXT4-fs (sda1): VFS: Can’t find ext4 filesystem
  3. can i the cloudshell screen showing info and lxde in the monitor? right now only cloudshell is showing

Remember i am newbie to linux and trying my best with help of google :slight_smile: so pls dont spit if it is silly issue :wink:


Thanks i managed to resolve the hdd problem. (Google :slight_smile: )

It was not ext4 its ntfs changing it in fstab resolved my problem.

now the next problem the autoboot option automatically goes to dietpi-cloudshell instead of lxde.

Hi Namaste ,

If you are planning to use this drive only on the XU4, i would recommend formatting the drive to EXT4 with 1 partition. You can do this during 1st run setup by selecting “yes” to “dedicated USB drive setup”.

now the next problem the autoboot option automatically goes to dietpi-cloudshell instead of lxde.

Kodi and LXDE: Desktop are not implemented yet on the Odroid XU4 image. You can run LXDE: Vnc server.

Regarding the autoboot options:
Make sure LXDE: VNC server is installed in DietPi-Software, then select that as the autoboot option. If this is still not being applied after a reboot, please could you send me a bugreport so I can check your settings:


I’ll only need the reference CODE:.

Thanks Fourdee,

HDD works perfectly. thanks

LXDE is also working now, one more question is it possible to have both hdmi have LXDE and small screen have cloudshell?

Can add some queries here are should be using another topic?

  1. JAVA8 on dietpi possible?
  2. to able to run custom application unicentosPOs (requires JAVA8) as autoboot ?
  3. possible to run without lxde like kodi does?

Thanks in advance

As far as i know, its not possible. I believe its a hardware limitation:
Reboot the board with HDMI cable disconnected and you should see already information going to the 2.2” LCD.

  1. JAVA8 on dietpi possible?


apt-get install oracle-java8-installer

  1. to able to run custom application unicentosPOs (requires JAVA8) as autoboot ?

From dietpi-config > autoboot. Select "Console: Automatic login. "
Then you can add the command to run the program in /root/.bashrc after /DietPi/dietpi/login

  1. possible to run without lxde like kodi does?

No idea. Never used or heard of unicentosPOs.

Checked Java Installer getting this error should i need to add different repo?

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package oracle-java8-installer

Google Says:

$ sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer

so installed additional python libz still no luck 404 where running java-installer

any other repo?

The DietPi image for XU4 already has the Java repo enabled by default:

Did you apt-get update?

didnt use the apt-get got it installed using:

PI Java Installer
Login to you Pi via ssh and run:

you download link from step 1

#wget > http://www.java.net/download/JavaFXarm/jdk-8-ea-b36e-linux-arm-hflt-29_nov_2012.tar.gz
wget > http://download.java.net/jdk8u72/archive/b05/binaries/jdk-8u72-ea-bin-b05-linux-arm-vfp-hflt-26_oct_2015.tar.gz
tar zxf jdk-8u72-ea-bin-b05-linux-arm-vfp-hflt-26_oct_2015.tar.gz
#rm jdk-8-ea-b36e-linux-arm-hflt-29_nov_2012.tar.gz
rm jdk-8u72-ea-bin-b05-linux-arm-vfp-hflt-26_oct_2015.tar.gz
sudo mv ./jdk1.8.0/ /opt/
sudo chown root:root -R /opt/jdk1.8.0/
sudo ln -s /opt/jdk1.8.0/ /opt/jdk8

Edit sudo nano -w /etc/profile and add these lines to the end of file:


Logout and re-login via SSH. Run java -version to see if java is working. You should see something like:

java version “1.8.0-ea”
Java™ SE Runtime Environment (build 1.8.0-ea-b36e)
Java HotSpot™ Client VM (build 25.0-b04, mixed mode)

working perfectly !