External HDD doesn't show up in file sharing


This is prob gonna be a difficult one, considering I’m a super noob.
But since I reinstalled my computer, I’m having trouble with my external hdd connected to my RP4.

First I could only read my files but couldn’t edit them through file sharing.
I tried some chmod’s, only to find out that I logged in with the wrong username in file sharing.
Somehow after this my external hdd doesn’t show up at all anymore and I also can’t log in as the root user in file sharing.

In drive manager it’s toggled as read only. I tried changing this in fstab, but automount keeps toggling it to read only.
Also with changing fstab and without opening drive manager, the external hdd still doesn’t show up.

If I connect my hdd to my computer directly, I can read, but that’s it.

Hope it’s a bit clear, but I have no clue what happened…

Thank you in advance!

Try to run an file system check, fsck
Most likely there are some errors detected which force the partition to be mounted read-only to avoid further corruption.

Ooh, thank you! I didn’t know that one yet.
Unfortunately I’m getting an error.

“Keys out of order
(8, 3)”

I think I will have to repartition my hdd…
But fortunately I can still copy my files!

Yes in case of filesystem errors, the drive is often automatically mounted read-only. But since you can still read files, you can copy/backup the partition to another drive at least. Copying will fail on the corrupted files as well of course, hence they will be missing, but very likely they are “only” a few system files, hence nothing that urgently needs to be backed up. If really personal data/settings are effected, you could have another look into /lost+found/ where files are parked which lost there inode, hence the their path, filename and attributes and such. The file size in such case might give a hint what it is and opening it with a related program could verify :wink:.

It took a while to copy 4tb of files, but everything is working again.
Seems like the problem was a bad/broken usb cable. ;o

Thanks for the help!