External drive has become Read-Only ??

Hello all, I’m quite enjoying my new ODROID C2 running DietPi, though I’m a total novice.

I have it set up running Plex Media Server, Kodi, and PiHole. I have a 2TB compact Seagate drive connected for media which worked perfectly for several days, but the last 2 days is saying Read-Only when I try to add files by FTP.

  • The 2TB drive is powered by the C2 (it has no auxillary power input, the C2 is using the Odroid 2A power supply)
  • The 2TB drive is formatted HFS+ unjournaled
  • I am using ProFTP in the Dietpi configuration to make changes to the media
  • I have moved the user data to the external media drive
  • I have checked the dietpi-drive_manager and it says the drive status “online and ready for use” and the Read only is “Disabled”
  • When I FTP in and try to add a file (like was previously working) here is what I get (Filezilla2 for Mac):

Status:      	Connecting to
Status:      	Connection established, waiting for welcome message...
Status:      	Logged in
Status:      	Retrieving directory listing...
Status:      	Directory listing of "/" successful
Status:      	Retrieving directory listing of "/TV Shows"...
Status:      	Directory listing of "/TV Shows" successful
Status:      	Creating directory '/TV Shows/New directory'...
Command:	MKD New directory
Response: 	550 New directory: Read-only file system

A little help please? Any ideas?

Are the directories and files in the PLEX directory under the user/group that PLEX is running as?

Did I mention that I’m a total novice :open_mouth:

I don’t understand all the parts of the question. I don’t think I have any user/groups set up, I still use the default login only for the device (root/dietpi), and within Plex I only have one user account.

I installed DietPi on the eMMC card, after getting DietPi installed I attached the external hard drive, in dietpi-drive_manager I transferred the user files to the external hard drive. The Plex media is going to the external hard drive, and when I connect by FTP to the device I could (last week) add files from my computer into this media directory (confirmed in drive manager the disk usage shows the media is going to the external drive).

Without a GUI file manager I don’t know how to see where the files are in the bigger picture. When I login with FTP the directory has Movies, Pictures, Music, etc. folders that I did not create (can’t say I’m sure if it was Plex or Kodi), and I can’t go up any further in the drive hierarchy.

What’s so strange to me is this was working fine last week, I could add, change, and delete files to the media drive over FPT.

Any more help out there?

If you reboot your system does it go read/write again
I know on my external, I had to put a /etc/crontab entry to touch the harddrive every 30 min to prevent it going to sleep
In /etc/crontab I added
30 * * * * root /bin/touch /dev/sda1 &>/dev/null

Command line in Linux is alot like DOS

cd = change directory
dir or ls = list directory
cd … goes back a directory

it’s a bit tricky and has a pretty hefty learning curve, but Linux is pretty straight forward
Have you tried to install webmin (GUI front end for alot of services on a Linux system, nice thing is you log in to http://ip.of.your.OPI:10000)

also typing mount will show you the mounted partitions/drives, look for /dev/sdb or something like that, that should tell you were the mounted external drive is located
mine shows /dev/sda1 on /mnt/a bunch of numbers (that is where your personal files are)

Thank you for the additional help.

When I reboot and try accessing the drive right away it still says read-only.

When I check ‘mount’ it gives me a long output, in two places I see the long drive name that I recognize for the 2TB external (recognize from seeing it in dietpi-drive_manager)

systemd-1 on /mnt/2f9afb70-312c-35d2-9c73-5c7a1ae90777 type autofs (rw,relatime,fd=24,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
/dev/sda1 on /mnt/2f9afb70-312c-35d2-9c73-5c7a1ae90777 type hfsplus (ro,noatime,umask=22,uid=0,gid=0,nls=utf8)

The second occurence I assume that ‘ro’ means read-only? Hmm. Yet in drive manager it says “Read only: disabled”.

The second occurence I assume that ‘ro’ means read-only? Hmm. Yet in drive manager it says “Read only: disabled”.

Thanks, this appears to be a bug, we’ll get this fixed.

Most likely a failing drive or insufficient PSU causing filesystem corruptions over time.

What happens when you try to remount the drive in RW?

mount -v -o rw,remount /dev/sda1

And check dmesg for any errors

dmesg | grep sda1

Thanks for the help, I ended up starting over from scratch with fresh DietPi on the eMMC, and this time formatted the 2TB external to ext4 from within the DietPi Drive Manager. Going on 2-3 days with no problem :crossingfingers: