Ext4-fs error Raspberry pi 4

Hello, for some time I’ve been having this problem with dietpi installed on my raspberry pi 4 4gb, the system is installed in an argon v2 case inside a 2 tb ssd m2, I use official power supply, and I use a dock station with a hd of 4 TB (orico), I would like some help on how to solve it, as the problem has appeared frequently

does the dock station has his own power supply or is it powered via the RPi?

Hi, own power supply

have a look to cable and connections. Somehow you have quite some disk errors

As well you could look to kernel error messages

dmesg -l err,crit,alert,emerg

Ah the issue is on device sda2. Can you check who this is

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
sda                    1.8T  0 disk
├─sda1  vfat   boot    256M  0 part /boot      8f4dbd00-01                          4ADC-240F
└─sda2  ext4   rootfs
                       1.8T  0 part /          8f4dbd00-02                          89cef7ba-d45a-47e7-8d42-aff18afcec80sdb                    3.6T  0 disk
└─sdb1  ext4           3.6T  0 part /mnt/Exos  9cef3430-f3f4-4485-9a1d-74f1dfc61588 9904cfcf-a5f9-4f76-9e5f-902c476f1eb8sdc                  476.9G  0 disk
└─sdc1  ext4         476.9G  0 part /mnt/Samsu 3947e9e0-b546-01d8-f0f0-a31ca35aec00 6af0dad6-b602-44b4-9893-afd8268130d0mmcblk0              238.3G  0 disk
│       vfat   RECALBOX
│                        3G  0 part            0e3de612-01                          8B27-5F7D
│       exfat  SHARE 234.3G  0 part            0e3de612-02                          418E-3CE3
        ext4   OVERLAY

Captura de tela 2022-09-07 200307

I didn’t have any more problems, maybe it was a bad fit of the argon case expanser board

hopefully it’s solved now.

have you tried

# touch /forcefsck

and a reboot (to force the system check the file system)

Ah I see it was a loose expansion board…that’ll do it